NextcloudPi with Nextcloud Box - no Spndown of HDD

i installed the great OOTB NextcloudPi. Everything works fine in the moment only my HDD won’t like to spin down. What can that be ?

maybe you are using cron instead of AJAX
it will do his job every 15 minutes, and if your HDD will spin down more than 15mins, it just won’t stop.
let your HDD stop often will shrink your HDD’s life, but if you decide to, change the settings in admin-server settings to ajax

Hello arily,
thanks for your quick request.
Yes i had cron instead AJAX. Now i change it and look what will happen.

ops sorry I forget that you need to delete the cron in crontab

you should delete the cron job in the crontab.
I don’t have a Raspberry Pi, so I don’t know who called that file.
for example in ubuntu uses sudo -uwww-data crontab -e to edit it.

ok. I am a noob.Where i need to do that ?

ok let’s first figure out who will calls cron.php
back to settings, The cron.php needs to be executed by the system user “www-data”.<- this is mine,
your user may not equal to me .

I think its the same. Im not shure. How i can proof this ?

just ssh into it and do this command

ah i understand. i have 1 more crontab placed

*/10 * * * * /media/USBdrive/updater/spdnsu

its my dns updater. This i also need to replace

sudo -uwww-data crontab -e -> ok. i see the job and pu now # before the line. is that ok so ?

yes that’s ok

did you know where i can see the spindown time from the WD HDD (a command or something like that)?

maybe you can use hdparam -I [your device such as /dev/sda]

no. i try it but hdparm did not work with WD HDD

I have a WD HDD too, it works fine. make sure you are not use your mounting point but the device like /dev/**

now the HDD spin down.