NextCloudPi Update from fails "Unable to generate a URL for the named route "

I am running NextcloudPI on a Pi 4 B 8Gb with a 512G SD for / and a 5T USB C external drive for my the NextCloud Data directory. It runs locally with limited remote access to the web interface only, using port forwarding on my router.

What I was trying to do:
Update my server to the latest stable version of NexrCloudPi.

What happened: (Short version)
I ran the web updater and it hung. After no log entries, I tried reloading https://myserver/updater/ and it tells me:

Current version is 25.0.8.
Update to Nextcloud 25.0.8 available. (channel: “stable”)

The nextcloud.log entries and my config tell me I’m still running

The main URL for my Nextcloud server is coming up 503.

Loading the updater from https://myserver/updater/ all the green checkmarks are there and clicking “Continue Update” the web ui seems to (very quickly) flash through all the steps, present the usual button at the bottom to continue with the web updater, and immediately sends me to https://myserver/ which then returns a 503 error.

What happened: (Long version)
The updater.log shows I began this process from version 24.0.9 to this morning. No errors.

Checking for further updates, I see that is available and begin that process, so I proceeded.

It hung on step 12. The updater.log ended with:

2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] request to updater
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] currentStep()
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] Step 11 is in state “end”.
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] POST request for step “12”
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] startStep(“12”)
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] finalize()
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] storage location: /mnt/data/nextcloud/data/updater-ocd899f3d2qj/downloads/nextcloud/
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] call opcache_reset()
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] end of finalize()
2023-06-23T13:54:23-0400 ZSpY2YhslZ [info] endStep(“12”)

I reloaded https://myserver/updater/ and after entering my update.secret, see all the green checkmarks and the indication that I am running 25.0.8.

I click the button to “Continue Update”. The rest of the list instantly populates and I see the button at the bottom flash and then the page immediately redirects to https://myserver/ which gives me a 503 error.

updater.log shows:

2023-06-23T13:58:38-0400 yZlUBt1VZd [info] request to updater
2023-06-23T13:58:38-0400 yZlUBt1VZd [info] currentStep()
2023-06-23T13:58:38-0400 yZlUBt1VZd [info] Step 12 is in state “end”.
2023-06-23T13:58:38-0400 yZlUBt1VZd [info] show HTML page
2023-06-23T13:58:38-0400 yZlUBt1VZd [info] current version: 25.0.8 build time: 2023-06-22T10:16:21+00:00 82f744bb016b059a55d1c6c476a665029e55cedc

I check the nextcloud.log file and find:

"message": "Unable to generate a URL for the named route \"cloud_federation_api.RequestHandler.addShare\" as such route does not exist.",

Full entries in nextcloud.log from that button click (prettified) are here: (expires in 30 days)

I’m at a loss. Short of trying to salvage the stored info and configs and re-installing fresh from scratch, I could use some help, please.

Any ideas?

If you use NCP you must use the NCP tools for updating. my server:4443 or the command line tool ncp-update-nc. Anything else will cause issues.

Where would I find these tools?

pi@server:~ $ sudo updatedb
pi@server:~ $ sudo locate ncp
pi@server:~ $

Perhaps I misremembered and I might be running NC on pi but not ncp? Is that a possibility?

Anything is possible, but it sure looks like no ncp on your system.
My ‘locate ncp’ returns multiple under /usr/local/bin/ncp and /usr/local/etc/ncp*