Nextcloudpi on Raspberry Pi 4B 8GB doesn't work

Dear everyone,

I tried to install the nextcloudpi image from late March on my raspberry pi 4B (8GB). Installation on the SD card, first connection via SSH (using PuTTY) and seeing the nextcloud visualization in a webbrowser works smoothly. However, it stops at the initial step in the browser with the message: “NextCloud not yet initialized, trying again in a few seconds”. Trying to initialize it on the terminal with “nc-init” results in a maria-database error. I really tried a lot, even installing raspbian followed by nextcloud via snap and never got it running due to several errors.

I now think that a 8GB model is not fully supported yet. So, will there be a 64bit nextcloudpi image that supports the latest raspberry 4B 8GB? Or are there any workarounds from users seeing similar issues?

Kind regards,

Have you tried the Ubuntu Appliance image? I believe I heard it works on the 8GB cause it uses Ubuntu Core and the version 18 snap. I’m assuming you could upgrade this snap to 19 after the Pi is powered up.

Ubuntu - Appliance - Nextcloud

There’s a link at the bottom of the page for a raspberry pi 4 that will download an image. Then you can image an SD card with the Pi Imaging tool.

Thank you timbuckto. I installed nextcloud core 18 on the SD card but the raspberry did not boot from it. Installing Ubuntu 20 LTS (64bit) followed by nextcloud-desktop. This finally worked! Now the nextcloud needs to be configured (external RAID, https, …). Is there an easy way to do so? Or are there any security risks doing it this way?

Hey there,
did you have any success with it and if yes what combo worked?

Hi Spekkk,

the latest release of Nextcloudpi finally worked.

Thanks und regards,

It is my first experience and first post on this forum. I am stuck on the “Network interface wlan0 WiFi configuration” screen, while installing ubuntu appliance core18 pi image on a rpi 4 8gb.
It appears that it is not accepting an otherwise valid password and the only reason i can think of is that my password has * and # symbols in it and if the keyboard for pi is not configured for type US then something else is passed on in the password. I can change the WiFi password on the router with the help of service providers but i think there should be a “hide”, “un-hide” sort of button on the passphrase to know at least that the correct password has been entered. I am not sure if I am right or wrong but I am posting with the hope to find some solution and highlight an issue if at all it is one .