NextCloudPi_OdroidHC2_12-19-19 does not boot on ODROID-XU4

Hi,

I downloaded ([https://ownyourbits.com/downloads/NextCloudPi_OdroidHC2_01-12-19/ ] and transfered it on a Micro-SD-Card, but the Odroid-XU4 does not boot. (The on-board switch is set to: boot-from-eMMC)

The same Hardware and SD-Card with an Ubuntu-Image boots and works without any problem.

Is this an known issue or is there somewhere a log file that contains any information why the device isn’t booting?

Thanks for any help,
garysn

thanks for reporting. I am generating a new image with the 4.14 kernel which we know that works. Would you be willing to try it out, see if it works?

Hi, that would be great :slightly_smiling_face:

I will test it as soon as it is available and give you feedback if it works.

I’m really interested in getting it working because I bought the hardware especially for building a NextCloudPi server and I can’t use it at the moment.

Awesome, thanks! even if the image doesn’t work there are two other ways you can make it work but I want to have a good image. It will be ready in a day or two

Okay, I will wait for the new image.

Thanks for your support!!!

https://ownyourbits.com/downloads/testing/NextCloudPi_OdroidHC2_01-08-20/

Hi, thanks for providing the new image. Unfortunatly it doesn’t work :frowning:

Here are the steps I have done on my Win 10 - 1803 PC:

  1. Downloading your file from the link
  2. Downloading the md5 file
  3. Checking md5 consistency
  4. Unpacking the .tar.bz2 with 7zip to .tar
  5. Unpacking .tar to .img with 7zip
  6. Starting Etcher Portable 1.5.63
  7. Select your .img file
  8. Connect my eMMC card (16GB) to my CardReader
  9. This card is auto-selected by Etcher as Target device
  10. Click on Flash
  11. Etcher tranfers the image to the eMMC card and then validates it.
  12. When ready i close Etcher and put the card into my ODROID-XU4
  13. I connect only a LAN cable and a power cable.
  14. The on-board boot select switch selects eMMC as boot device
  15. The ventilator starts to run, the ethernet leds starts blinking, that’s all
  16. When I connect a Monitor via HDMI and a mouse, keyboard and external SSD -> same result
    No desktop ist displayed, no IP address is assigned (I have checked this on my router)

To check if I do anything wrong I exactly repeated the above steps but this time I used the standard Ubuntu image that I had downloded from the ODROID website.

With this image my ODROID-XU4 starts Ubuntu and runs without any problems.

I hope this helps to find the problem.

Again thanks a lot for your support.

garysn

This works on my board, so I am not sure what you are doing wrong, of whether there is a kernel bug on some board revs.

I suggest you try a Debian Buster image and use the curl installer.

If I get more reports like this then we will be able to get more information, hopefully from somebody that can debug through serial.

Note that these images are based on Armbian, so you could try an Armbian image and see if that works for you. You can use the curl installer there, or use softy since NCP is included in Armbian softy.

Armbian doesn’t work, too.

My board has REV 0.1 20180912, what is your revision.

If it is different then I will try to exchange the board against another one.

Observing the same here.
Downloaded https://ownyourbits.com/downloads/NextCloudPi_OdroidHC2_01-08-20/ unpacked it with winrar and wrote the .img file to emmc with etcher.
My display is not starting and the system is not booting.

Got the same REV as garysn 0.1 20180912 .

Are we having any options now?

Oakley

If the Armbian image doesn’t work for you the next step is to make them aware in the Armbian forums. They will fix it.

Hi nachoparker,

this was a goog hint.

The armbian guys told me that I have to prepare the bootloader of the emmc card in a special way to get it to run.

Here are the links:
https://forum.armbian.com/topic/7545-cannot-get-xu4-emmc-to-boot/
https://docs.armbian.com/User-Guide_Getting-Started/#how-to-install-to-emmc-nand-sata-usb

And here are the steps that I have done:

  1. Use Etcher to burn a Armbian image on an µSDCard.
  2. Install the µSDCard and the eMMC card on the XU4
  3. Change the boot switch on the XU4 board to “Boot from SD” position
  4. Connect Network, Keyboard, HDMI an Power to the XU4
  5. The system boots Armbian
  6. Log in as user ‘root’ using password ‘1234’
  7. Create a new user (you are forced to do so by Armbian)
  8. run the following line on command line: sudo nand-sata-install (see link above)
  9. select option 2
  10. shut down system
  11. remove µSDcard and eMMC card
  12. Connect eMMC card to PC and burn Nextcloud image with Etcher on it
  13. Disconnect eMMC card from PC and install it to XU4 board
  14. Switch XU-4 boot mode from SD card back to eMMC card
  15. Boot XU-4
  16. Now NextcloudPi is running (at least on my board)

Thanks for your support !!!
garysn

Aloha nachoparker,

I am new to this forum. My question? I have an Odroid-HC1 and your image

would this image (…NCP_OdroidHC2_01_08_20) work for an Odroid-HC1???
To my knowledge the difference is an HC2 is for a larger(TB) SATA Hard Drive. But the enclosed SBC is just a reduced Odroid-XU4.

Any links for installing NCP on a Odroid-HC1 would be greatly appreciated!

Mahalo,
Douglas

https://docs.nextcloudpi.com/en/curl-installer/

Unfortunately I have to confirm that neither the nextcloud image nor the armbian image boots on the Odroid HC1. Also an attempt with OMV failed.
In my experience with the raspi, the sd card had to have a boot partition and a rootfs partition.
Etcher and dd always create only one rootfs.
The blue LED flashes: short, short, pause.
Also exchanged hardware was unsuccessful (HC1 and SD cards).

I put my request to the Armbian forum. Hope, they can help.

First of all, thank you so much for that! It worked for me with a minor modification:
For step 9 I had to chose option 3, e.g. the last on the list. Option 2 did not work, perhaps because it updated the bootloader on the SD only.