NextCloudPi: Nothing happens after "Initializing NextCloudPi for the first time"


I tried to run NextCloudPi in the docker container with the command

docker run -d -p 4443:4443 -p 6443:443 -p 6080:80 -v ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf

There is an nginx reverse proxy on the machine to provide different applications (docker containers) on the same port.
In the logs “Init done” is shown but the browser shows (no matter if I access it from the Internet via the reverse proxy nor locally);

Initializing NextCloudPi for the first time
Please wait…


Starting PHP-fpm
Starting Apache
Starting mariaDB
2018-09-29 5:07:04 1995870208 [Note] mysqld (mysqld 10.1.26-MariaDB-0+deb9u1) starting as process 75 …
Provisioning Redis password
Updating NextCloud config with Redis password
Provisioning MariaDB password
Updating NextCloud config with MariaDB password
PHP threads set to 4
Starting Redis
Starting Cron
Starting Postfix
System config value trusted_domains => 1 set to string
Init done
In some older forum posts there is a much longer logfile. Am I “missing” any logs?

On the RaspberryPi “docker-ce” is installed, since the docker container couldn’t be loaded with

pi@raspberry:~ $ docker run -d -p 4443:4443 -p 443:443 -p 80:80 -v ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf
Unable to find image ‘ownyourbits/nextcloudpi-armhf:latest’ locally
latest: Pulling from ownyourbits/nextcloudpi-armhf
dbc234a865ab: Pulling fs layer
Pulling repository
Tag latest not found in repository

Could this be an issue, using docker-ce instead of (sorry, total docker noob).

I have exactly the same issue, I am also using docker-ce and the second last line of my log file says “Starting redis-server: redis-server.” and finishes then with “Init done”. My solution for now is to use the full Raspberry Image instead of the docker image.

this is not the first time you run the container, you probably didn’t clear the ncdata volume.

Try to stop and remove the container, and remove also the volume before issuing docker run


Thank you, that’s it.
As I said, I’m a docker noob. I tried to restart the container the container with the full run command as stated in my first post. If anyone facing the same problem, just start the docker container with

docker start >container-id<

The container ID can be found with

docker ps -a

One-liner if you NextcloudPi container was the last to exit:

docker start ‘docker ps -q -l’

thanks, deleting the volume worked for me as well

Hello guys. I have the same problem and don’t get it fixed. I did 1 to 1 what the manual says
I installed docker and this docker-compose. The panel works great with but the real NextCloud is stuck at Initializing NextCloudPi for the first time. Please wait…
I already removed the container and the volume and did the same process again. Can you help me?


I think I found the solution.
After waiting a sufficient amount of time (15 min?) I found the window that was reloading and reading “Initializing NextCloudPi for the first time. Please wait…” I simply altered the URL from
https://myserverip:443 to https://myserverip/nextcloud

This brought me to the happy blue admin login window.

i had the same issue. (I am using a Raspberry PI 3B+). I also tried to remove the volume, but it did not work for me.
On the nextcloudpi admin interface (https://yourIP:4443) : I updated the nextcloud app from 18.x to 19.x. Strangly, this solved the problem. (I went through the upgrade to version 21 after that. It is stils working).
Good Luck.