Nextcloudpi distro upgrade to Bullseye fails with "unmet dependencies" error (SOLVED)

Nextcloudpi version: (Nextcloudpi v1.47.2)
Operating system and version: Debian GNU/Linux 11. 5.15.32-v8+ (aarch64)
Apache or nginx version :
PHP version:

The issue you are facing: I tried to upgrade the nextcloudpi distro because when running nc-info, it was one of the suggested actions. When I ran sudo ncp-dist-upgrade, the upgrade commenced (after the few confirmation messages ofc) but it eventually failed with the following error:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
smbclient : 
Depends: samba-common (= 2:4.13.13+dfsg-1~deb11u3) but 2:4.13.13+dfsg-1~deb11u4 is to be installed
Depends: samba-libs (= 2:4.13.13+dfsg-1~deb11u3) but 2:4.13.13+dfsg-1~deb11u4 is to be installed
Depends: libwbclient0 (= 2:4.13.13+dfsg-1~deb11u3) but 2:4.13.13+dfsg-1~deb11u4 is to be installed
E: Unable to correct problems, you have held broken packages.                                                           Something went wrong. Fix it and try again

Also, a larger problem at the moment is not that the distro failed to upgrade, but that ever since it did, the nextcloud web interface (including the nextcloud panel) just show the php code instead of the actual interface ;( I believe that it has been caused by the failed distro upgrade because this started happening right after the failed upgrade. (which leads me to believe that if I can successfully finish the upgrade then this other problem will also most likely be solved)

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Just run “sudo ncp-dist-upgrade”? (That’s all I did that brought me to this error)

Nevermind, I have fixed this. For anyone else with the same problem, here’s what I did:

sudo apt update
sudo apt --fix-broken install
sudo apt upgrade
sudo apt-get install smbclient
sudo apt-get install php

Excuse me if I typed any of these commands wrong, because I am writing from the top of my head. I hope this can help out anyone else with the same problem :slight_smile: