Nextcloudpi container status is up (docker) but cannot communicate after power outage

Nextcloud version: Unknown, but installed fresh 2 weeks ago (roughly 5/22?)
Operating system and version: Raspbian stretch (I don’t know version number, sorry)
Apache or nginx version: Unknown - installed via docker
PHP version: Unknown

The issue you are facing:

Cannot navigate to any web interfaces after power outage.

Unfortunately I’m not much of a software guy so I’m not sure how to get some of the requested info. But to describe my situation: 2 weeks ago I decided to install nextcloud on my raspberry Pi. I installed the then latest version of raspbian and a friend mentioned docker might be a good idea for Nextcloud installation. I configured fstab to automount a 1TB USB drive and partitioned it with space for the docker container and space for the data to be stored separately. I’m pretty sure I have a wrong understanding of how these are segmented and how docker works, but that’s how I configured it. I do have the command’s I’ve run saved so here they are:

pi@hostname:~ $ curl -sSL | sh
pi@hostname:~ $ sudo usermod -aG docker pi
pi@hostname:~ $ newgrp docker
pi@hostname:~ $ sudo nano /lib/systemd/system/docker.service
#edit ExecStart=/usr/bin/dockerd -g /media/USB/NCapp/Docker -H fd:// 
pi@hostname:~ $ sudo nano /lib/systemd/system/docker.service
pi@hostname:/mnt $ docker run -d -p 4443:4443 -p 444:443 -p 8080:80 -v /media/USB/NCstorage/ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf cloud.[domain].[tld]

You’ll note I’m not using all standard ports as I have a VPN to my home network as well as pihole running on my pi as well, so I wanted to leave 80 and 443 alone. I have a nat translation rule in my firewall so public access is actually over 443 like it should be.

This worked GREAT. Unfortunately while getting a new ISP today I bumped the power cord on my pi and it went down hard. It came back - weird. Pi hole didn’t autostart, but worked after manually starting. I knew I had yet to configure autostart for Nextcloud so I ran
docker start nextcloudpi
and it seemed to start running, but I couldn’t get into any web interface via local network or internet. I tried configuring autostart and also rebooting my pi, but it seems to not be working and I have no idea how to troubleshoot. Any help? For what it’s worth, if there’s a way to just re-install while keeping my client user/data intact this would be fine with me.

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Power on pi
  2. Run docker ld and verify nextcloudpi is “up”
  3. attempt to navigate to https://[local-network-IP]:4443 (or 444 or https://[publicdomain].[tld])
  4. get a 404 on your browser

The output of your Nextcloud log in Admin > Logging:
Is this from the web interface? I can’t get there.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):
Given that I’m using docker, I’m not sure how to do this. Sorry.

The output of your Apache/nginx/system log in /var/log/____:
Given that I’m using docker, I’m not sure how to do this. Sorry.

I haven’t heard much on this, but I’m starting to wonder if there isn’t something more wrong with my OS as I can’t get X to start at all either. I’m probably gonna take a different tack and focus on recovery and not repair. If you have any ideas, feel free to let me know though.

if you are seeing random errors, you probably are using a bad power supply/SD card