NextcloudPI backup to external harddrive

Hi, I’m currently using an Odroid HC-1 with a sata connected 4tb harddrive for data storage. I’m looking at a backup strategy for data and settings.
I’ve read Nacho’s post and wanted to go the BTRFS route. When I plugged my external usb harddrive into the Odroid I couldn’t find a way to just format the external drive using the WebUI. So I ran an Ubuntu Live CD to get Linux long enough to format the harddrive with BTRFS. I then attempted to plug-in the harddrive back into the Odroid but rather than calling it USBDrive1 it bumped my internal HDD to USBDrive1 and called the external USBDrive. This caused Nextcloud to throw a fit because it could no longer find the datadir. Is there a way to use NextcloudPI automount to mount the external harddrive as USBDrive1 as opposed to USBDrive?

Alternately I have a HTPC running Windows 10 which would be a preferable place to back everything up to but I cannot seem to get WinBTRFS to install properly.

Unfortunately I don’t know enough about Linux to create scripts or run Cron jobs, but is there another way to backup everything to the HTPC?

From what I understand the Rsync only backs-up the Datadir.


When formatting your drive, use a LABEL to name your drive.
nc-automount will mount your drive as /media/yourLABEL
If you use /media/yourLABEL/ncdata to move data to, it can no longer be confused by other drives mounted after.

For backups: I use nc-backup-auto without data for config and database and nc-snapshot-auto and nc-snapshot-sync for data. Works for me :wink:

Ah that makes sense. I used Gparted and gave the partition a name, but I just found out that a Name and a Label are two different things. Thank you so much. I’ll give that a try.

Doesn’t nc-snapshot-auto automatically backup config and database?

No, it only takes a snapshot of the data folder, that is why you need nc-backup-auto to make backups of NC’s config and db.

Looks pretty cool in the new Backups/Snapshot Restore tool in NCPWeb:

So the issue I’m facing now is that somehow I pointed my DataDir to “USBdrive” instead of it’s mountpoint “myCloudDrive”.

Then, if I try to move the datadir to myCloudDrive nextcloudpi sees there is data there, makes a backup and then throws a fit saying it can’t move the datadir afterall.

Is there anyway of moving the datadir from USBdrive to the actual mountpoint without Nextcloudpi complaining?


ncp.log output would be helpful here.

You can use terminal to edit path to data in config.php
Run nc-fix-permissions and nc-scan after that.

Output of

ls -lh /media/
Should show that USBdrive is a symbolic link to the actual drive

Thank you sooo much. Changing the path in config.php worked perfectly. Just running NC-Scan now just to be sure.

1 Like