Nextcloud21, Nextcloudpi, PHP8.0.2, Mysql

Hallo, ich bin eigentlich gut zurecht gekommen mit Nextcloudpi als Image, das ich Anfangs geflasht hatte auf meinen Raspi 4.

Jedoch folgende Szenarien sind mir untergekommen, wo ich sorgen habe, ob etwas falsch konfiguriert wurde.

Zuerst, hatte ich das Image geflasht mit Nextcloudpi, 20.0.4 und dies habe ich immer aktuell gehalten auf stable.

Danach hatte ich nach ner Zeit php7.3 auf 7.4 aktualisiert und hatte das Problem das Nextcloudpi nicht mehr richtig arbeitet, also die WeboberflÀche

Eine Zeit spĂ€ter bin ich dann auf Nextcloud Beta umgestiegen und habe auf php8.0.2 aktualisiert und die Cloud lĂ€uft eigentlich einwandfrei und habe nen grĂŒnen Haken bei der ÜberprĂŒfung.

Jedoch in der Protokollierung finde ich folgende Fehler und wollte Mal fragen ob ich sorgen haben muss?

ErrorPHP2021-02-19T10:27:30+0100
Required parameter $tagManager follows optional parameter $fileIdentifier at /var/www/nextcloud/apps/files/lib/Helper.php#220
Warningno app in context2021-02-19T10:27:25+0100
Invalid data provided to provideInitialState by files
ErrorPHP2021-02-19T10:27:25+0100
Required parameter $internalPath follows optional parameter $mountId at /var/www/nextcloud/lib/private/Files/Config/CachedMountFileInfo.php#34
ErrorPHP2021-02-19T10:25:06+0100
Error: Required parameter $internalPath follows optional parameter $mountId at /var/www/nextcloud/lib/private/Files/Config/CachedMountFileInfo.php#34
ErrorPHP2021-02-19T10:10:09+0100
Error: Required parameter $internalPath follows optional parameter $mountId at /var/www/nextcloud/lib/private/Files/Config/CachedMountFileInfo.php#34
Warningno app in context2021-02-19T10:07:46+0100
Invalid data provided to provideInitialState by files
Warningno app in context2021-02-19T10:07:16+0100
Invalid data provided to provideInitialState by files
ErrorPHP2021-02-19T10:04:53+0100
Required parameter $tagManager follows optional parameter $fileIdentifier at /var/www/nextcloud/apps/files/lib/Helper.php#220

Falls wer nen Tipp hat wie ich einen sauberen Log erstelle fĂŒr weitere Informationen, bitte um den Hinweis der Kommando Befehle fĂŒr den Terminal :sunglasses:

Danke vorerst Mal :+1:

Hoffe es kann mir wer weiterhelfen? :slight_smile:

Nextcloud21, Nextcloudpi, PHP8.0.2, Mysql

Du hast eine Testversion, ich empfehle dir als AnfÀnger eine Stable Version, also Nextcloud 20.0.7.

Wenn Du stable Nextcloud nicht beherrschst, sollte man nicht zu beta Nextcloud wechseln.

Ist mir schon klar


Wenn ich nicht komplett klar gekommen wĂ€re mit der stable, sowie viele andere auch, die sich hier einlesen, hĂ€tte ich bei der Beta jz keinen grĂŒnen Haken


Wollte lediglich wissen sowie hundert andere auch was meine Fehler bedeuten und wo ich anstoßen kann 


Sicherlich da, evtl. gibt es mit PHP InkompatibelitÀten.

Da kann ich dir aber nicht weiterhelfem, ich bin AnfÀnger.

1 Like