Nextcloud won't start but it should have

Nextcloud AIO v8.0.0
Ubuntu 22.04

This is weird.

I let a laptop sync over night. This morning it was done - all looking good. I reboot my nextcloud server this morning and it would not start.
Nextcloud container stuck in Starting mode.
I checked the logs

ncadmin@nextcloud:/mnt$ sudo docker logs nextcloud-aio-nextcloud
[sudo] password for ncadmin:
Connection to nextcloud-aio-database ( 5432 port [tcp/postgresql] succeeded!

2024-03-23 13:24:33.268298-07
(1 row)

2024-03-23 14:11:49.387417-07
(1 row)

  • ‘[’ -f /dev-dri-group-was-added ‘]’
    ++ find /dev -maxdepth 1 -mindepth 1 -name dri
  • ‘[’ -n ‘’ ‘]’
  • set +x

I pasted this log into chatgpt to see what it said and it says the container should be running.

What am I missing? Where else I can look for further troubleshooting?



On further investigation here is what I found.

My ncdata folder is on a NAS drive which has worked for months and I could always access it from any computer on the network and write to it, but for some reason I couldnot write to it anymore externally.

I fixed it by plugging it directly into my windows 11 machine and giving other users write access recursively. Then plugged it back into my router.
Nextcloud containers were able to boot this time and everything syncing again

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.