Nextcloud with REDIS on local network

Hello,

I am looking to activate REDIS on a Nextcloud instance.
The REDIS server is installed on a local network machine and the connection requires a username and password.

Does the Nextcloud configuration allow the REDIS username to be specified? Is it simply via “username”?

Currently when I enter my data I have an “internal server error” and in the logs: “read error on connection to 192.168.0.200:6379”

My code is :

'filelocking.enabled' => true,
  'memcache.locking' => '\OC\Memcache\Redis',
  'memcache.local' => '\OC\Memcache\Redis',
  'redis' => array(
  'host' => '192.168.0.200',
  'port' => 6379,
  'timeout' => 0.0,
  'username' => 'YYYY',
  'password' => 'XXXX',
  ),

REDIS CLI is OK :

root@nxt-1:/var/www/vhosts/AAAA/httpdocs/data#  redis-cli -h 192.168.0.200 -p 6379 --user YYYY --askpass
Please input password: *********************
192.168.0.200:6379> 

Thanks in advance,

Hello,

You don’t need a username afaik. Your conf file should be as follow.

'memcache.local' => '\\OC\\Memcache\\Redis',
'memcache.distributed' => '\\OC\\Memcache\\Redis',
'filelocking.enabled' => true,
'memcache.locking' => '\\OC\\Memcache\\Redis',
'redis' => 
array (
  'host' => 'REDIS_SERVER_IP',
  'port' => REDIS_INSTANCE_PORT,
  'timeout' => 0.0,
  'password' => 'REDIS_INSTANCE_PASSWORD',
),