Nextcloud with ceph as primary storage

I am trying to set up nextcloud using an array of ceph buckets as primary storage. I have 2 separate instances of nextcloud running. Using the first I successfully configured ceph buckets to be used as external storage through the external storages app. The issue is some of the functionality of external storage is not the same as primary storage such as Nextcloud’s quota management.

All the tutorials point to altering the config.php or creating a storage.config.php file before completing the setup through the web interface. Attached is what I added to my storage.config.php file before running the setup on the web interface.
<?php
$CONFIG = [
‘objectstore_multibucket’ => [
‘class’ => ‘OC\Files\ObjectStore\S3’,
‘arguments’ => [
‘bucket’ => ‘abc’,
‘key’ => ‘’,
‘secret’ => ‘’,
‘hostname’ => ‘ceph.ex.com’,
‘port’ => 7480,
‘use_ssl’ => true,
‘region’ => ‘’
‘use_path_style’ => true,
],
],
];

After filling in the information I get an internal server error every time. (I have tried reinstalling nextcloud several different times)
The only thing that I can pull that is useful from the log located at /var/www/html/nextcloud/data/nextcloud.log is this line: " “user”:“admin”,“app”:“core”,“method”:“GET”,“url”:"/nextcloud/index.php/core/apps/recommended",“message”:{“Exception”:“Aws\S3\Exception\S3MultipartUploadEx
ception”,“Message”:“An exception occurred while initiating a multipart upload: Error executing “CreateMultipartUpload” on…”

Are there any additional logs that I can find more information from. Or does anyone see any obvious flaws with my setup process?

Any advice is appreciated.

Yes, the multibucket configuration is wrong. And since you’re using the default 7480 port for ceph S3 instead of 443 I’m curious on if you have a working and valid SSL certificate.

I would recommend contacting your systems administrator and have them setup your system for you.

I am the systems administrator. I am new to Nextcloud and trying to figure out how it integrates with ceph. For now I am not worried about SSL certificates yet since we are in a testing phase. I will set that up later.

You said that the multibucket configuration is wrong. Can you give an example of a correct multibucket configuration?

‘use_ssl’ => true,

So which is it? Are you using ssl or not? You say you’re not but your nextcloud config says you are.

You’re missing the region. You’re missing the parameter to define how many buckets are created.

I just pulled the config from a tutorial I was following and forgot to update the use_ssl to false. In my config it is set to false, and the region is included in my config and correct because as I mentioned I can connect my buckets as external storage using the same region.
I would just need to add the following line?
‘num_buckets’ => 4,

Okay! As long as you understand the default ceph regions. Guess I don’t need to go into details about that. :slight_smile:

Yes, that’s the parameter. Good luck!

I was able to get Nextcloud installed properly with a multibucket configuration, but I noticed that every time I run the install with num_buckets = 64 (or any large number) it only creates 2-3 buckets. I can’t find any documentation about when the buckets are supposed to be created but I would imagine that they are supposed to be created all at once when you install.
Do you have and additional information on this subject?