Nextcloud web-interface too slow

This is me first time trying Nextcloud and my impression is Nextcloud is somehow slow. To be honest, annoyingly slow. Whatever I click in web-interface, I have to wait a few seconds till I see something. Even the front login page takes ~5 seconds to show. Is this normal?

My VPS (kvm) has 2 cores of E5-2643, 4GB ram (plus 4GB swap), 50GB ssd and full speed 1gbit eth. Software-side it is debian 10 with mariadb and nginx. I think it should be enough to play around a little with Nextcloud. It is basically nothing more than empty Nextcloud installation, with two users, no files uploaded, no addon-apps.

Admin-page shows no warning. I use only local storage, previews are disabled, PHP-caching is active (OPcache, APCu for local and Redis for file locking). For php I increased memory to 512MB and increased number of start/spare php-fpm servers to 10. All processes together are using ~700MB of RAM, ~2GB for buffers/cache, rest is free. Load is 0.03/0.03/0.00. Disk i/o is ~150MB/s. Connection to my VPS is good, with no packet loss (100mbit/optic, but I also tested 80/30mbit LTE).

Just for comparison: I have one more VPS-2 with exactly the same HW-configuration, the same location and provider, with a few web-sites running Drupal (definitely not light-weight CMS). Compared to Nextcloud it is blazingly fast! I even switched Nextcloud from VPS-1 to VPS-2 to see if there is any difference, but none I could observe.

So why is Nextcloud web-interface so slow, and what can I do to improve it?

If you’ve eliminated the hardware as a possibility, and we know this isn’t normal behavior for Nextcloud, and you presumably don’t have a slow/problematic connection on your client end, then by process of elimination this is probably a configuration issue.

I’m not an nginx user, I don’t mean to point fingers, there are plenty of nginx setups that run fine… but I will say I have personally noticed a pattern of people reporting performance issues and using nginx in some fashion.

If you’re not averse to trying something a little different, I would suggest trying Apache, or using Docker. I wrote a guide for doing a Docker setup on Ubuntu, but I expect it would adapt easily to Debian.

Just for comparison, I installed Nextcloud on one more VPS, with even better HW (8GB ram, 4x cpu, 200GB ssd/nvme). I followed Nextcloud admin-guide step by step, included all tweaks for php/mariadb/nginx mentioned there. And the overall speed/responsiveness is about the same: web-interface is annoyingly slow. I do not know what to do more. Apparently I’m not using HW effectively, as cpus are mostly sitting idle and 6 out of 8GB ram is free.

Is there some Nextcloud performance/tuning guide?
Any tips for mariadb/mysql tunning?
What default apps/modules could I disable to increase overall performance?

If few seconds means 1-2-3, then I have the same. I consider it normal…

I have a few WordPress server sitting right next to Nextcloud. Their web interface IS more responsive… Maybe twice…

All those servers run on my own VMware cluster in a university setting…

Is mariadb local or networked? Are you using php-fpm?

Mariadb is local. I’m using php-fpm with 120/12/6/18 servers (max/start/minspare/maxspare) and 512M memory limit.

With “slow”, I mean I have to wait 4-5 seconds just to get the login-page. And after I log in, everything is even slower. Sometimes I press “reload” after 10 seconds when I’m sick of waiting any longer. By far the slowest web I have ever seen…

As I mentioned before, since we know this isn’t normal behavior, and the hardware has been eliminated, it’s most likely a configuration issue of some kind.

If you still want to troubleshoot it, why don’t you set one up using Docker following my guide? I have set up several running in VMware ESXi using that process and haven’t had the problem you describe on any of them.

That is definitely not common…

That I noticed a few times. After pressing login it takes a while…
Reload helps… I think it has to do with browser cache…

Good thing you haven’t used v.17…
Logging off on some browsers took 10-15 seconds…:slight_smile:

Do you have the App Files access control installed? We noticed the app generates a lot of error messages and slows down the web interface. After removing (not only disabling) the app the error messages were gone and the web interface was a lot snappier again. Maybe that will help you too.

Files access control version 1.9.1 & 1.10.0

See: Flow activation: rules were requested for operation Block

3 Likes

Wow, you weren’t kidding about File Access Control slowing down the web UI. I just disabled it and it’s instantly blazing.

1 Like

Hi there!
We have installed Nextcloud v23.0.2.1 using Docker & Portainer.
It used to work properly for the first few days but after a while it got TOO slow. The people here are complaining about a delay of 4-5 seconds but our problem is much much more serious…!
Every single page seems to be extremely slow.
We need to know if we have to change our configuration settings or to disable the few applications we have already installed on Nextcloud, or the problem belongs to MariaDB, or Nextcloud itself.
We will be thankful if you help us fix the problem cos it is really annoying.

Just FYI for the people here, in case anyone is interested:

I opened a separate thread about my problem and it is related to this one.