Nextcloud Web buggy, not usable

Hi there,

I ran in to trouble by setting up my nextcloud server. Somehow i went in to some permission Problems (I’m a linux newbie), I coudln’t get it fixed. So i simply deleted the whole nextcloud directory and unzipped a clean original version.

The config site (without config.php.PNG) looks not normal , so there is nothing better than before.
After copying the config.php back, it looked like before. (That was the reason why i reinstalled nextcloud). The problem is, there is no login Screen before and no way to click anything.

Are there still any permission problems on the files?

At this time i didnt edit any permissions, after unzipping nextcloud inside linux.

Do you guys have any Ideas what could solve my problem?

Im running nextcloud with the following specs:
Ubuntu with Plesk
Nextcloud 12
PHP7.0

There are no LogFiles at the moment, because it’s a newly installed server. I couldn’t find anything. And there is no way to get them over WEB.

my config.php look like the following:

    <?php
$CONFIG = array (
  'instanceid' => 'ocileofoady568',
  'passwordsalt' => 'o',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => 'xxxxxx.zzzzz.de,
  ),
  'datadirectory' => '/nextcloud_data/',
  'overwrite.cli.url' => 'https://xxxxxx.zzzzz.de',
  'dbtype' => 'mysql',
  'version' => '12.0.2.0',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => true,
  'mail_smtpmode' => 'sendmail',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'nextcloud',
  'mail_domain' => 'xxxxxx.de',
  'logtimezone' => 'Europe/Berlin',
);


PS: The first pic shows nextcloud with my config.php. And the second one without any configs.
PSS: Uploading via my phone and syncing everything works fine. So WebDAV is working, i think.

Best regards,

Felix

First off, I would look at regenerating your password salt and secret and your database password :grimacing: since now there is information about your server that’s exposed which could result in complete compromise of data security.

Now to the topic at hand: run these 2 commands

find /path/to/your/nextcloud/install/ -type d -exec chmod 755 {} ;
find /path/to/your/nextcloud/install/ -type f -exec chmod 644 {} ;

Be sure to change the path to correctly fit the actual path to your nextcloud data

Also, change ownership of the files with
chown -R www-data:www-data /path/to/your/nextcloud/install

I’ve removed the credentials, please don’t expose them if you want your systems to remain secure and definitely change them now.

Don’t worry, i locked my domain, nobody can access it for now.

Thank you for you’re device, i will try those commands.

Sorry, this goes to @JasonBayton

Don’t worry, i added and removed some characters inside the lines you removed.

But thank you very much!

Just by the way:

There is a Problem, i run Plesk on my Server. Php runs under plesk at an other user. nginx and apache runs in the group www-data.

Should i set the ownership like the following?

chown -R MyUserThatRunsPHP:www-data /path/to/your/nextcloud/install

Sorry for asking such Linux newbie questions. :zipper_mouth_face:

First of all i will try out what you just wrote before.

Thank you guys!

I executed all commands succesfully. You’re chmod command didn’t work, i used “chmod -R myPHPUser:www-data”

But it still doesn’t want to work well. I get the same site than before. :sleepy:

Are there any more solutions for me? :confused:

Thank you guys!