Nextcloud VM Appliance 20.0.0

Just wanted to let you know that the latest version of Nextcloud (20.0.0) now is available to download as with the Nextxloud VM Appliance. You can download it here:

There’s been a lot of improvements and I’m personally exited about this release as it contains many new features.

Nextcloud 20.0.0 is an amazing release, great work team!


Hi Daniel,

Thank you for your VM. I installed version 20.0.0. Can I ask questions here that I noticed at this point? Or is there another place / contribution?

Thank you very much

I wanted to report that everything has worked for me since today.

At the weekend I carried out the update to VM Applinance 20.0.0. I was probably too quick :wink: , some apps weren’t deployed.

Bild-00 10.10.2020

Today I installed the apps. It seems that everything is working.

Just for your information, I get the following error message when I run your script. I just have to wait and it will work.

Thank you for the very good job.

Hey @Faulpelz, I gonna try to answer your post.

Great to hear, thanks!

This has most likely something to do with the appstore problems in the last week.

Okay, good.

Yes, please only use /var/scripts/ to access any menu. Everything is reachable by running this script.

Thanks again!


Midnight Commander

Cool :wink: I don’t know what to say, that was a big topic for me in the past, maybe you can still remember it and now you’ve made it available. Perfect, thank you very much, I’m happy. :+1: :fist_right: :fist_left:

Thanks for the hint with, I didn’t notice.


How to live without mc ? :wink:

1 Like

In the early MS DOS 3/4 days - Linux wasn’t conceived yet! - some Eastern European DOS manuals claimed Norton Commander to be part of DOS itself - very few could imagine living without it…:slight_smile:

Midnight Commander is just a Linux clone of it…

So what?
Are you still selling Norton Commander? :wink:

I don’t…
The point was: MC/NC existed long before Linux was born.

And so did life!..

1 Like

Haha! :joy:


1 Like

I have a small problem. I updated NC from version 20.0.5 to 20.0.6.

I had activated twofactor_totp for the NC administrator. After the update, the twofactor_totp app is no longer available.

Previously (picture from the internet)

After / now
Two-factor authentication
At least one of your two-factor authentication methods could not be loaded. Please contact your administrator.

Two-factor authentication is being enforced, but has not been configured for your account. Use one of your backup codes to sign in or contact your administrator for assistance.

I don’t necessarily need it. I would disable it. However, the app cannot be deactivated because the app is no longer available. Now I always have to log in with the backup code.

Now I always have to log in with the backup code.

I also moved the app directory and restarted the server, but unfortunately it didn’t help either.

The search results:
Bild - 003 28.01.2021
Bild - 004 28.01.2021

That’s the only thing I can find:

This is what it looks like in the admin settings

Does anyone have any idea how I can turn off two factor registration. Many thanks

@Faulpelz please look here:

1 Like

@ChristophWurst fixed this just yesterday with Fix/app fetcher php compat comparison by ChristophWurst · Pull Request #25335 · nextcloud/server · GitHub . See the PR for details. You might be able to patch your instance.


I also brought this up to our release team as it’s a very unfortunate regression for some apps and it looks like we will be able to do the 20.0.7 a bit earlier and it might land next week.

Sorry for any inconveniences caused.


Thank you, it works again with the update to 20.0.7. Many thanks also to the NC developers for providing the update quickly.

Bild - 001 04.02.2021

1 Like