Nextcloud-virtualdrive-techpreview-v2: TLS initialization failed error

I was going to give a try to virtualdrive-techpreview-v2 build, but can’t even log in to well functioning over HTTPS (TLS 1.2) NC instance:
“Failed to connect to Nextcloud at TLS initialization failed” message occurs, giving another 3 options to connect (without my valid https). Any ideas?

1 Like

Hey! I have exactly the same problem, my server runs in TLS1.2 and it’s impossible for me to switch all in 1.3 only for a test, knowing that the official apache2 package is not updated yet to support TLS1.3 therefore, is it an obligation for the “virtualdrive-techpreview-v2 build” to connect to a TLS1.3 protocol or is it a bug?

1 Like

Hey! Same here, seems that no one uses tech preview v2. I bet over 90% of nc 16.X installations will have standard TLS 1.1 & 1.2 env. Tech preview v1 was not usable for me / us too. Don’t know why this previews are released when no one can use it.

1 Like

Same Problem here.
This client is completely useless for enterprise environments.
1st of all it was big announced in January 2019.
Now we have October and just Tech Preview 2 available, which - to be usable - let’s me brick my Ubuntu LTS Server just to make some fancy TLS1.3 available.

I’m really fed up with this piece of software. Might be useful for home-users but in no way ready for enterprise.

1 Like

Same here. My Debia is running TLS1.2, my Client is Win10 Pro. Normal Client is working, Tech Preview not. Any chance to enable old TLS Versions?

Ask that on Github maybe @camila will take care of this demand.

Same Error. Should be fixed so that testing can begin.

Regards Franz

is there any other thing that i miss?

i have setup my Nextcloud

client still says TLS error

Hi all.

I’m not a Nextcloud contributor, just some guy having issues as described here.

At least for me, the issue is nothing to do with TLS versions or anything in my Nextcloud server config. The issue is entirely to do with the techpreview-v2 client installation. It seems that this client installation package is missing the libssl DLL file.

  • Install the normal/latest Nextcloud Windows client
  • Copy the file “C:\Program Files\Nextcloud\libssl-1_1-x64.dll” to a safe location (e.g. your Downloads folder).
    • If you can’t find the file in this location, try “C:\Program Files (x86)\Nextcloud”
  • Uninstall the Nextcloud client and install the tech preview version. Don’t launch Nextcloud when the installation finishes.
  • If you browse to “C:\Program Files\Nextcloud” in Windows Explorer, you might find that “libssl-1_1-x64.dll” doesn’t exist. Drop in the backup copy you made.
  • Launch Nextcloud.

If you are as lucky as I was, the tech preview of the virtual drive will work and you can start testing.



Hey Shaun. Brillant. It worked …

…just to see how far VD is from Prod-Ready.

Immensivly slow…