Nextcloud Virtual Files 3.13.0 Crashing Seconds After Launch

I’ve just installed Nextcloud 3.13.0 VFS on my M3 Pro MacBook Pro and it crashes 1-2 seconds after opening the program. I run the program using Spotlight and it launches, as I can see it in Activity Monitor and within the top bar but after launch it crashes. No report of the crash or error message, just instant crash. I have uninstalled and reinstalled it and the same thing happens, I then installed it on my 2015 MacBook Pro and that too isn’t working.

I have also tried to install 3.12.6 and 3.13.0, both of which work completely fine but unfortunately I really want to use the Virtual File System as I’m migrating from Dropbox and not being able to see my online online files is a real pain. When running 3.12.6 or 3.13.0 normal version I try to update or switch to the beta channel but I get the following error:

Update Error!
An error occurred in retrieving update information. Please try again later.

I’m running Nextcloud off of my TrueNAS Scale server at home and connecting to it using the IP address. No issues on the server as far as I’m aware and I’m pretty sure its the Mac program.

Nextcloud version: 3.13.0 VFS
Operating system and version: macOS Sonoma 14.1.1 and 14.5.0
Apache or nginx version: Unknown
PHP version: Unknown

If you need any specific logs let me know how I can access and provide them as I’ve not used this forum before. Any help to get VFS working would be brilliant!

Thanks in advance! Matt