Nextcloud v.16 auf v.17 Update Problem (HTTP ERROR 500)

Hay how,
ich habe vor 2-3 Tagen meine Nextcloud von v.16 auf v.17 geupdatet bzw. hatte es vor, nachdem das Update durchgelaufen ist, wurde zunächst die “maintenance” Seite angezeigt nach ca. 1-2 min. wurde meine Nextcloud neu geladen und seitdem wird mir ausschließlich nur noch “HTTP ERROR 500” angezeigt (vor dem Update habe ich natürlich kein richtiges Backup gemacht, weil zuvor die Updatefunktion immer ohne Probleme funktionierte :roll_eyes:), nun stehe ich da mit meinem Talent und weiß nicht was ich noch probieren könnte, außer das bei der Updateroutine automatisch ein Backup erstellt worden ist aber wo finde ich dieses?! (und wie lasse ich dieses wieder zurück spielen)?!

Installiert ist mein Nextcloud-Serever auf einem RPI4 mit 4GB, alles was ich bisher gefunden habe bzgl. meines Problems half mir nicht weiter :frowning: .

PS: ich hab noch ein etwas älteres Backup dort sind schon einige Sachen korrekt eingestellt aber eben nicht alles :confused: am liebsten wäre es mir wenn ich meine aktuelle Installation i.wie retten kann.

PS: Auf das Backend (NextcloudPi) kann ich ohne Probleme zugreifen.

Wäre MEGA wenn mir wer auf die Sprünge helfen könnte.

Gruß
Frosch/Sven

I am also using RPi4 with 4GB RAM, and I also got HTTP ERROR 500 after upgrading from 16 to 17.

This fix worked for me:

cd into nextcloud dir (cd /var/www/nextcloud)

sudo -u www-data php occ upgrade

Hope this helps you too.

Thank you for your answer, I tried it in the past, but it does not work. :frowning:

Hat denn niemand einen weiteren Hinweis/Tipp für mich? :frowning:

Die Meldung ist aus meiner Sicht eindeutig, es gibt ein Problem mit dem von Dir gesetzten memory_limit-Wertes in der PHP-Konfiguration. Wie hast Du den Wert dort genau gesetzt?
Der angezeigte Wert “6291456000” (6000 * 1024 * 1024?) lässt vermuten, dass dieser deutlich zu groß gesetzt wurde.

Wenn Dein RaspberryPi nur 4GB RAM verbaut, hat, dann ist es unwahrscheinlich, dass man nahezu 6GB für PHP zur Verfügung hat. Ich würde da eher mit einem Wert von z.B. 512MB beginnen.

memory_limit = 512M
1 Like

VIELEN Dank für deinen hinweis, ich habe tatsächlich an dieser Stelle etwas eingetragen gehabt allerdings ist dies schon eine weile her und in NC v.16 lief es ohne Probleme (jedoch einen so hohen Wert hab ich dort nicht eingetragen)

Ich werde an dieser Stelle mal gucken ob ich darüber den Fehler beheben kann :wink:

Um die Ursache besser verstehen zu können wäre interessant zu wissen welchen Wert Du dort genau eingetragen hast?!

Jedenfalls einen zu hohen (über 4GB) ich meine ich habe dort 6GB eingetragen,

weil ich keine größeren Dateien als 4GB uploaden konnte bzw. immer noch nicht kann :frowning:

6 * 1024 * 1024 * 1024 => 6442450944 :wink:

Dieser Parameter hat NICHTS damit zu tun, bis zu welcher Größe Dateien hochgeladen werden können. Siehe:

https://www.a2hosting.com/kb/developer-corner/php/using-php.ini-directives/php-maximum-upload-file-size

Also ich hatte dort 512M anstatt 128M eingetragen, habe es jetzt wieder auf 128M umgestellt funktioniert jedoch immer noch nicht. (Ggf. habe ich die falsche Datei angepasst (/etc/php/7.3/fpm/php.ini))

Das es dort eig. nicht eingestellt wird, hab ich mir bereits gedacht gehabt jedoch jegliche anderen Änderungen haben nicht zum erfolg geführt… .

Und in der Nextcloudconfig stehen ziemlich wenige Zeilen gegenüber was dort vorher drin stand (soweit ich mich erinnere) [/var/www/nextcloud/config/config.php], es gibt noch eine config.sample.php in der stehen sehr viele Zeilen (so wie ich die Config in Erinnerung habe) jedoch ist dies eine “cleane” config) (wie komme ich an meine urspründliche Config?) HILFE :stuck_out_tongue: :frowning:

Hallo,
als Tip vielleicht: Es könnte auch sein, dass über die Web-Server-Konfiguration die entsprechenden Parameter zur Speicher-Verwendung des PHP eingestellt sein (muss nicht in einer php.ini sein).
(Sitze gerade leider am falschen Rechner, um die konkrete Beispiele angeben zu können.)
Schau mal in der Apache-Konfiguration zu dem Virtualhost der Nextcloud-Instanz, oder ggf. sogar in einer .htaccess in der Webserver-Root zu der Nextcloud-Instanz (eventuell gibt es sogar sowas wie eine .user o.ä.) - dort könnten Einstellungen beginnend mit PHP_ o.ä. drin sein.

Viel Glück.

1 Like

Es gibt einmal eine PHP-Komponente für den WEB-Zugriff (fpm) und eine Komponente für den Kommandozeilenzugriff (cli). Du hast nun scheinbar nur die erste Konfigurationsdatei angepasst, nicht aber für das Kommandozeilenprogramm. Vieleicht findest Du mittels des folgenden Befehls die richtige Datei:

grep -R "memory_limit" /etc/php
1 Like