Nextcloud upgrade deletes all files

Hi all,

I have an interesting problem… not sure why it’s happening. The short version. When I am trying to upgrade a docker instance of Nextcloud from to it deletes all my user data.

the detail:
I have a Proxmox Server and am running an Ubuntu 22.04 LXC Container. I run Docker inside this container with Nextcloud and a MariaDB instance. On the proxmox server I have a CIFS mount to a Truenas box for my user data. This is then mapped as Bind mount to the container and the config file points to here for the user data. The rest of the config etc is on local storage.

I run a “docker-compose pull” to grab the latest image and then run a “docker-compose up -d” to complete the upgrade.

It then sits for a while and if I run a “docker logs nextcloud” I get the output:

Initializing nextcloud …
Upgrading nextcloud from …

this sits for about 10mins or so, and if I observe in the background I see the files being deleted from the Userdata directory and eventually the users folders too. (I take regular backups of the data so when I realised what was happening it was all good - and now I can spin up a test environment in mins)

just for clarity I have no performance issues or anything running in my current setup. everything operates exactly as it should.

does anyone have any ideas on what may be happening??