Nextcloud Update von 28.0.1 auf 28.0.2 Problems

Hello!

I upgraded from Nextcloud 28.0.1 to 28.0.2 today using the Pi, unfortunately I get this error in the security and setup warnings:

Could not check for JavaScript support. Please manually check if your web server serves `.mjs’ files with the JavaScript MIME type.

Can anyone help me?
I am using a Pi 4 with Portainer

Many thanks in advance
lg
Sepp

Same problem here.
I added ‘appiication/javascript mjs’ in the Nginx mime.type file, but the message persists.

The same issue I have!

  • occurred after upgrading from 28.0.1 to 28.0.2.
  • occurs only if access from the local network
  • if access from my public domain - the issue doesn’t exist.
    Please advise how to fix it.

I also can confirm this behaviour.
There is alrrady a bug filed and it should be
fixed in 28.0.3

I also experienced the error after upgrading to 28.0.2 the error appeared and this is the solution I made based on what I read.

my webserver I enable https which means I have a certificate that is generated or self-signed for local connection only.

error:
Could not check for JavaScript support. Please check manually if your webserver serves .mjs files using the JavaScript MIME type.

Solution:
sudo -u apache php occ security:certificates:import /etc/ssl/certs/apache-selfsigned.crt

then the error message disappeared

thanks

2 Likes

Thanks will wait for the next update and hope it will be fixed then

1 Like

I’ve tried using that import crt command and still doesn’t resolve it for me. My instance is actually behind HAProxy on pfsense that is using let’s encrypt certificates so makes me think the checks aren’t taking that setup into account?

I added an entry to my host file on Debian 11 and it seems to have fixed this error.

sudo nano /etc/hosts

added

127.0.0.1 your.nextcloud_domain.com

1 Like

I have created a new topic

I have a similar setup, and I am experiencing the same error. Did you get a resolution to this?