Nextcloud update error

Hi, I cannot update nextcloud. I tried both the CLI and web interface. I have Raspberry Pi OS Lite 11 (bullseye) and NextcloudPi installed via docker on Raspberry Pi 4 hardware. NCPi was updated to v1.46.7 without problems. Everything seems OK, nextcloud works good, but the update fail with this output:

Running nc-update-nextcloud
Current   Nextcloud version 21.0.4.1
Available Nextcloud version 22.2.2
Download Nextcloud 22.2.2...
Error downloading
Clean up...
Done. Press any key...

I’ve searched for this topic and I have not found anything helpful. I’ve tried e.g. to disable UFW or to recreate the docker container (to have fresh NCPi installation)…

Could be the problem, that I use Raspbian 11 and NCPi is for Raspbian 10?

Please use CLI with this command and post errors:

sudo -u www-data php updater/updater.phar

If you use NCP you need perhaps other update ways.
Sorry. I do not use NextCloudPi
Read there the documentation for upgrade.
Staying up to date | NextCloudPi Documentation

Thanks, this way works, it is not recommended in the NCPi docs though, so I hope I’m OK:

methods, including NC’s native updater, may or may not work, use at your own risk

Back to what I have done, the command for docker is something like:

sudo docker exec -it nextcloudpi-test sudo -u www-data php /var/www/nextcloud/updater/updater.phar

I ran it several times, update versions were: 21.0.421.0.922.2.523.0.2

So, if this way worked while the NCPi official update tools didn’t, should I report issue at github? I think this has something to do with the docker.

I’m having the same issue with docker