Nextcloud update error from 12.0.x to 12.0.3

I have tried auto-updating nextcloud from ver.12.0 but have never succeeded.
I’m manually updating 12.0.1 and 12.0.2 respectively. In both cases, an error occurs at a very early stage and stops.

The suspicious items in the remaining updater.log file below.
TRY_UPDATING_DATE&TIME J1b3v1kzyh [info] request to updater
TRY_UPDATING_DATE&TIME J1b3v1kzyh [info] currentStep()
TRY_UPDATING_DATE&TIME J1b3v1kzyh [info] POST request for step "1"
TRY_UPDATING_DATE&TIME J1b3v1kzyh [info] startStep(“1”)
TRY_UPDATING_DATE&TIME J1b3v1kzyh [info] checkForExpectedFilesAndFolders()
TRY_UPDATING_DATE&TIME J1b3v1kzyh [error] POST request failed with UpdateException
TRY_UPDATING_DATE&TIME J1b3v1kzyh [error] Exception: UpdateException
#0 /NEXTCLOUD DIRECTORY/updater/index.php(1251): Updater->checkForExpectedFilesAndFolders()
#1 {main}
File:/NEXTCLOUD DIRECTORY/updater/index.php
[0] => nextcloud.log

TRY_UPDATING_DATE&TIME J1b3v1kzyh [info] rollbackChanges("1")
TRY_UPDATING_DATE&TIME J1b3v1kzyh [info] unlink .step
TRY_UPDATING_DATE&TIME J1b3v1kzyh [info] end of  rollbackChanges()
TRY_UPDATING_DATE&TIME JNbRmvpuno [info] request to updater
TRY_UPDATING_DATE&TIME JNbRmvpuno [info] currentStep()
TRY_UPDATING_DATE&TIME JNbRmvpuno [info] POST request for step "1"
TRY_UPDATING_DATE&TIME JNbRmvpuno [info] startStep("1")
TRY_UPDATING_DATE&TIME JNbRmvpuno [info] checkForExpectedFilesAndFolders()
TRY_UPDATING_DATE&TIME JNbRmvpuno [info] end of checkForExpectedFilesAndFolders()
TRY_UPDATING_DATE&TIME JNbRmvpuno [info] endStep("1")
TRY_UPDATING_DATE&TIME 82fzqthWwZ [info] request to updater
TRY_UPDATING_DATE&TIME 82fzqthWwZ [info] currentStep()
TRY_UPDATING_DATE&TIME 82fzqthWwZ [info] Step 1 is in state "end".
TRY_UPDATING_DATE&TIME 82fzqthWwZ [info] POST request for step "2"
TRY_UPDATING_DATE&TIME 82fzqthWwZ [info] startStep("2")
TRY_UPDATING_DATE&TIME 82fzqthWwZ [info] checkWritePermissions()
TRY_UPDATING_DATE&TIME 82fzqthWwZ [info] end of checkWritePermissions()
TRY_UPDATING_DATE&TIME 82fzqthWwZ [info] endStep("2")
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] request to updater
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] currentStep()
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] Step 2 is in state "end".
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] POST request for step "3"
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] startStep("3")
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] setMaintenanceMode("true")
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] configFileName /NEXTCLOUD DIRECTORY/updater/../config/config.php
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] end of setMaintenanceMode()
TRY_UPDATING_DATE&TIME sw5NYXO4xl [info] endStep("3")
TRY_UPDATING_DATE&TIME brMjdwL7RZ [info] request to updater
TRY_UPDATING_DATE&TIME brMjdwL7RZ [info] currentStep()
TRY_UPDATING_DATE&TIME brMjdwL7RZ [info] Step 3 is in state "end".
TRY_UPDATING_DATE&TIME brMjdwL7RZ [info] POST request for step "4"
TRY_UPDATING_DATE&TIME brMjdwL7RZ [info] startStep("4")
TRY_UPDATING_DATE&TIME brMjdwL7RZ [info] createBackup()
TRY_UPDATING_DATE&TIME vFe35a2kde [info] request to updater
TRY_UPDATING_DATE&TIME vFe35a2kde [info] currentStep()
TRY_UPDATING_DATE&TIME vFe35a2kde [info] Step 4 is in state "start".

It is commonly occurring in my past two update tasks.
I want to use automatic update to 12.0.3.

Also, can I delete the “data/updater-oc???” folder?

Nextcloud version (eg, 10.0.2): 12.0.2
Operating system and version (eg, Ubuntu 16.04): CentOS 7.3
Apache or nginx version (eg, Apache 2.4.25): nginx 1.11.13
PHP version (eg, 5.6): 7.1.9

I think I’m having a similar issue updating owncloud 10.0.3 to nextcloud 12.0.3. I’m getting the “Updates between multiple major versions and downgrades are unsupported” error message.

Entirely different and known issue, pop your error into search (top right) and you’ll see many of the same topics for that.

When it fails, do you see a more user-friendly error than this? Looks like it could be failing at the check for expected files/folders.

I trying update now.

Check for expected files
Check for write permissions
Enable maintenance mode
Create backup
Parsing response failed. Step 4 is currently in process. Please reload this page later.

only this.
I tried chage permission and user(root/nginx).

I have seen other threads, but others seem to have problems somewhat. I also manually update it this time. Manual updates are troublesome. And I’m afraid of failure. I think that this method is most certain if it takes time… I have never experienced an automatic update yet. I hope that automatic update will be possible in the future.