Nextcloud über Reverse Proxy

Hallo zusammen,

ich habe einen Nextcloud Server installiert und einen Reverse Proxy davor.
Auf beiden Systemen läuft ein Apache2 Webserver.
Das ganze läuft auch so wie ich es mir Vorstelle.
Nur ich bekomme auf der Übersicht folgende Meldungen angezeigt und die würde ich gerne bereinigen.
Ich habe zwar schon gegoogelt und ein paar Sachen ausprobiert aber die Meldungen gingen nicht weg.

Könnt Ihr mir weiterhelfen?
Welche Daten braucht Ihr noch von mir?

Gruß
T

  • The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.

  • The “Strict-Transport-Security” HTTP header is not set to at least “15552000” seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips :arrow_upper_right:.

  • Your web server is not properly set up to resolve “/.well-known/caldav”. Further information can be found in the documentation.

  • Your web server is not properly set up to resolve “/.well-known/carddav”. Further information can be found in the documentation.

Moin,

ich würde erstmal ohne reverse Proxy versuchen, um den Fehler zu herauszufinden, ob es wirklich am rp liegt. Wahrscheinlich hast Du das schon gemacht. Un hast Du die Dokus auch befolgt?

Gruß

Haydar

Hi,

sorry für die späte Reaktion.
Bin aber noch nicht zum Testen gekommen.
Ohne RP habe ich es leider noch nicht getestet.
Ja die Anleitungen habe ich befolgt.

Gruß
T

Hi,

  1. Punkt
    In die Nextcloud Konfiguration folgender Eintrag am besten über ‘trusted_domains’ => setzen (IP-Adresse anpassen, ist die des Reverse Proxys) Vorsicht, die Hochkommas werden hier im Forum falsch formatiert!

‘trusted_proxies’ =>
array (
0 => ‘192.168.1.1’,
),

  1. Punkt
    Im Apache des Reverse Proxys das Modul header laden und diesen Eintrag in der VirtualHost anlegen:

Header always set Strict-Transport-Security “max-age=31536000; includeSubDomains; preload”

3./4. Punkt
In der Nextcloud VirtualHost des Apaches diesen Eintrag ergänzen:

Redirect 301 /.well-known/carddav https://cloud.example.com/remote.php/dav
Redirect 301 /.well-known/caldav https://cloud.example.com/remote.php/dav

@helge

Danke für die Antwort aber scheinbar kriege ich es trotzdem nicht hin.
Ich wollte auch meine Konfigurationsdateien hochladen aber das funktioniert nicht so wirklich.
Hochladen kann ich nur Bilder und wenn ich es als Text eingebe wird es durch die Sonderzeichen wie “<” irgendwie formatiert und es fehlen etliche Zeilen.

Hab es trotzdem mal als Bild hochgeladen.

Nextcloud Konfiguration

Reverse Proxy - Virtual Host Datei

Gruß
DerT

@DerT
Mit deiner Reverse Proxy / VirtualHost stimmt was nicht. Wenn die Verbindung vom Reverse Proxy zur Nextcloud VirtualHost nicht über das Internet statt findet, kannst du das SSL dem Reverse Proxy überlassen und gehst dann unverschlüsselt zur Nextcloud VirtualHost.

So würde ich es machen. Ich hoffe das es passt, da ich es nicht nachkontrollieren kann. Leider auch als Bild da Code hier im Forum nicht funktioniert.

Port 8080 für Nextcloud VirtualHost aktivieren
vi /etc/apache2/ports.conf
Listen 8080

Voraussetzung, alle Module für header, proxy, rewrite sind geladen.

Nachdem ich mich länger nicht mit dem Thema beschäftigen konnte habe ich aber eine Lösung gefunden.

Mir aufgefallenen, dass meine “VirtualHost” Datei total konfus war und habe diese noch einmal komplett neu aufgebaut.

Für alle die das Problem auch haben hier die Datei mit der es funktioniert hat.

<VirtualHost *:443>
  ServerName nextcloud.example.com
  ProxyPreserveHost On
  DocumentRoot /var/www/nextcloud
  ProxyPass /.well-known !
  ProxyPass / http://nextcloud.angl.loc:80/
  ProxyPassReverse / http://nextcloud.angl.loc:80/

  SSLCertificateFile /etc/letsencrypt/live/nextcloud.example.com/fullchain.pem
  SSLCertificateKeyFile /etc/letsencrypt/live/nextcloud.example.com/privkey.pem
  Include /etc/letsencrypt/options-ssl-apache.conf

  RewriteEngine On
  RewriteRule ^/\.well-known/carddav https://%{SERVER_NAME}/remote.php/dav/ [R=301,L]
  RewriteRule ^/\.well-known/caldav https://%{SERVER_NAME}/remote.php/dav/ [R=301,L]

  <IfModule mod_headers.c>
    Header always set Strict-Transport-Security "max-age=31536000; includeSubDomains; preload"
  </IfModule>

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

PS.
Man kann im Forum code Posten in dem man ihn mit zwischen zwei Zelen mit ``` schreibt.

```
Code
```