Nextcloud through Cloudflare tunnel not working but all my other Dockers are

Hi,

I have Nextcloud running as an Unraid Docker. It works fine on the local network.

I have a Cloudflare Tunnel working to the Unraid server. All my other dockers work fine through the tunnel.

That led me to believe it must be my config file and “trusted proxies”. However, I have included my domain through which the tunnel runs and still no joy.

Please have a look at my config and comment if there are any errors. Are there any other avenues for me to check?

Thanks for looking.

Paul

$CONFIG = array (
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘datadirectory’ => ‘/data’,
‘instanceid’ => ‘ocxxxxxxxxxxxxxxw’,
‘passwordsalt’ => ‘TBxxxxxxxxxxxxxxxxxxxxxxDoy’,
‘secret’ => ‘dFxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxnRHo’,
‘trusted_domains’ =>
array (
0 => ‘nextcloud.pxxxxyz.com’,
1 => ‘localhost’,
2 => ‘10.10.10.30:444’,
),
‘dbtype’ => ‘sqlite3’,
‘version’ => ‘25.0.1.1’,
‘overwrite.cli.url’ => ‘http://10.10.10.30:444’,
‘installed’ => true,
‘theme’ => ‘’,
‘loglevel’ => 2,
‘maintenance’ => false,
‘updater.secret’ => ‘$2y$10xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx232’,
);

same problem here…running local:443 everything is fine; just can’t get it through the tunnel , i have been working on it for a week trying to figure out what can cause such an issue, since every other server (around 6 servers) can be access from the internet only nextcloud failed (or maybe refuse) to do so; i tried nginx and apache2 same result…just confused

update …now i can get a 503 error nice :tada:…i know server is down will be 502 error