Nextcloud the server was unable to complete your request

Hi,
I installed latest nextcloud on a ArchLinux with mariadb and I got this error:

nextcloud

the server was unable to complete your request

The nextcloud.log looks

https://termbin.com/f9ar

with jq

https://termbin.com/8rtp

Nginx access log looks like this. No error log

2a02:168:a774:0:74a7:21a8:ae44:48bb - - [23/Jan/2022:12:52:37 +0000] “GET /nextcloud HTTP/2.0” 500 2532 “-” “Mozilla/5.0 (X11; Linux x86_64; rv:96.0) Gecko/20100101 Firefox/96.0”
2a02:168:a774:0:74a7:21a8:ae44:48bb - - [23/Jan/2022:12:52:41 +0000] “GET / HTTP/2.0” 500 2532 “-” “Mozilla/5.0 (X11; Linux x86_64; rv:96.0) Gecko/20100101 Firefox/96.0”

What is wrong?

Can’t only access localhost nextcloud? Or wrong php-fpm version ? Or wrong mariadb?

… denied to user ‘nextcloud’@‘localhost’ …

Make sure that the given database user is allowed to manipulate the Nextcloud database tables.

Ok. Thanks for answering. I‘m not very common with sql. So I did All privileges but seems not to work! What I have to do exactly? I have a user nexcloud and a table nexcloud. So how I can give nextcloud „superuser“ rights and also admin? Thanks for reply.

I did

GRANT ALL PRIVILEGES ON . to ‘nextcloud’@‘localhost’ WITH GRANT OPTION;

+---------------------------------------------------------------------------------------------------------------------------------------------+
| Grants for nextcloud@localhost                                                                                                              |
+---------------------------------------------------------------------------------------------------------------------------------------------+
| GRANT ALL PRIVILEGES ON *.* TO `nextcloud`@`localhost` IDENTIFIED BY PASSWORD '*HASH' WITH GRANT OPTION |
| GRANT ALL PRIVILEGES ON `nextcloud`.* TO `nextcloud`@`localhost`                                                                            |
+---------------------------------------------------------------------------------------------------------------------------------------------+

but the user admin can’t find it in the the table nextcloud?!

I fixed with

chown -R http:http /etc/webapps/nextcloud/config
chmod -R 750 /etc/webapps/nextcloud/config

Now I have the problem that the apps are not writeable ?!

nextcloud2

I did

chmod -R 0770 /usr/share/webapps/nextcloud/apps 

but it didn’t fix it

php-fpm have write access to the folder.

How to fix it?

You have to make sure that the “http” user has write accesss to that directory. Additionally you should check yor Nextcloud configuration, especially the setting of the apps_paths parameter.

I got it. Thanks for a support. A little bit anoying is that I have to redo that every time when ArchLinux push a upgrade but that is a OS problem

1 Like