Nextcloud Terminal Version Update Command

I am using Nextcloud 24.0.4 and I am unable to update to version 24.0.6 due to my “OPEN UPDATER” button not working. It does not launch the updater app and instead it takes me to the Nextcloud dashboard,

I need help performing the update manually using the NextCloud terminal interface. When I open the terminal I see the text below in the Nextcloud terminal:

root@NextCloud:/var/www/html#

What is the Nextcloud install update command to type in after the “#” (number hash) character shown above to manually install the 24.0.6 Nextcloud Update successfully?

In the Linux Mint world the commands below usually are the commands used to perform an update:

sudo apt get
sudo apt upgrade

Obviously, this will not work for updating Nextcloud manually, therefore I hope somebody in the community can share with me the correct version update command I need to use. Thank you for your time.

usually this manual page should help you.
more to the bottom of the manpage you’ll find the command line build in updater

https://docs.nextcloud.com/server/latest/admin_manual/maintenance/update.html

If “hanging updates” block the process please check if there are .step files in your /data/updater … dir.

Remove the .step file in the /data/updater…/ folder and follow the instructions from the manual above.

Thank you for your post Chrissi55. I tried looking for an Updater folder and as shown in the Nextcloud terminal output text below there is no Updater folder to be found.

Additionally, the link you provided doesn’t show any path that points me to the location of the “.step” file you mention.

Can anybody in the community please post the correct Nextcloud Terminal command I need to use for the purpose of updating my Nextcloud to version 24.0.6 manually using the Terminal.

My “Open Updater” button is broken. It does not invoke the updater app. So please somebody please post the update command I can use inside the Nextcloud terminal to perform a manual update to version 24.0.6. Thank you.


root@NextCloud:/var/www/html# cd data
root@NextCloud:/var/www/html/data# ls
ME  appdata_ocfkosyil84g  files_external  index.html  nextcloud.log
root@NextCloud:/var/www/html/data#

Can somebody in the Nextcloud community PLEASE help me with the following matter. What command do I need to enter into my NextCloud Terminal for the purpose of updating my NextCloud from v24.0.4 to v24.0.6. I need to perform the update using my terminal because clicking on the blue colored “Open Updater” does not work. Please help. Thank you for your time.

Can anybody in the community please post the correct Nextcloud Terminal command I need to use for the purpose of updating my Nextcloud to version 24.0.6 manually using the Terminal.

Seen this in the manpage?

Chrissi55,
Thank you for your post. I tried the sudo command in the screen shot at two different command line terminals.

The first attempt was executed at the Pi Os terminal command line as shown below. This resulted in getting this error: “sudo: php: command not found”

piadmin@raspberrypi:~ $ sudo -u www-data php --define apc.enable_cli=1 /var/www/nextcloud/updater/updater.phar
sudo: php: command not found
piadmin@raspberrypi:~ $

My second attempt was executed at the Nextcloud terminal command line as shown below. This resulted in getting the same error: “sudo: php: command not found”.

root@NextCloud:/var/www/html# sudo -u www-data php --define apc.enable_cli=1 /var/www/nextcloud/updater/updater.phar 
bash: sudo: command not found
root@NextCloud:/var/www/html#

My question to anybody in the community is why is Nextcloud rejecting the “sudo” command? Does Nextcloud have a ROOT level I need to get access to in order to make this updater command work from the Nextcloud command line? Additionally, changing apc.enable_cli to 1 did not help either.

My Nextcloud was installed using the CasaOS docker-compose feature. It runs within CasaOS as a docker app. Additionally, CasaOS runs on top of the Raspberry Pi 64bit OS. And all of this software is running on a Raspberry Pi 4 8GB single board computer.

Any advice welcome.

docker app
Sorry i can not really help. But read this. With docker the commands differ from the documentation posted above.

For upgrade docker container in CasaOS watch this video.

Devnull, thank you for the link to the video. I followed the instructions and I was finally able to apply the v24.0.6 update. I was hoping I would see the new Nextcloud Hub 3 version installed after performing my update but it looks like that is not the case. I guess if I want to install the new Nextcloud Hub 3 release it is going to be a lot more complicated than just applying an incremental update.

Lastly, applying the v24.0.6 update has given me the new error shown below. Does anybody in the community know why updating from v24.0.4 to v24.0.6 will cause such an error to appear? Any advice welcome.

* Some columns in the database are missing a conversion to big
 int. Due to the fact that changing column types on big tables 
could take some time they were not changed automatically. By
 running "occ db:convert-filecache-bigint" those pending changes 
could be applied manually. This operation needs to be made while 
the instance is offline. For further details read [the documentation 
page about this
 ↗](https://docs.nextcloud.com/server/24/go.php?to=admin-bigint-conversion).

  * file_metadata.id

Nextcloud Hub 3 aka Nextcloud 25 is still a release candidate. I’m not using Nextcloud in Docker myself, so I could be wrong, but afaik there are no official docker images available for pre-release versions of Nextcloud

As the message suggests, you can fix that by running occ db:convert-filecache-bigint inside your Docker container. Assuming you are using the official Nextcloud Docker Image, the command would look like this:

docker exec --user www-data CONTAINER_ID php occ db:convert-filecache-bigint

Make sure to replace CONTAINER_ID with the actual ID of the container.

See also here: docs/README.md at master · docker-library/docs · GitHub