Nextcloud Talk Signaling Server - now automated installation

Hello everyone!

Just wanted to let you know that we made it possible to install the new HPB (Talk Signaling Server) in the Nextcloud VM. The setup is totally automated, just a single command and the script takes care of the complete installation. That’s what I call awesome.

You can read more about it here:

You can get the script itself here (you need the RAW file):

@rakekniven and other forum admins, please spread (spreed) the word. More users should know about this. Also, would be nice to stick this news for a few days at least.

Thanks!

Have fun with it!

14 Likes

Thank you!

Have you used it with more than a handful of people?
If so, how does it perform?

Hello,

thank you for the hard work. Pinned it globally.

Have you seen the german manual for setting it up? :

Can I run it on the NUC I bought in your shop?

Thanks!

No haven’t seen that guide actually.

Yes, it’s fully compatible! :slight_smile:

When we tested we were 3 people on a very bad 4G, and it worked. :slight_smile:

Try it out and report back. :wink:

Oh, forgot to mention, just run sudo bash /var/scripts/menu.sh from your CLI and voliá!

1 Like

Should I post bugs here? It´s possible that is my mistake… first time-script-user!

Certs are generated!
Enabling site talk01.MyDomain.net.
To activate the new configuration, you need to run:
systemctl reload apache2
Config value signaling_servers for app spreed set to.......

# Stay here für 1-3 minutes#
# Then...

Installation failed. :/
Please run this script again to uninstall if you want to clean the system, or choose to reinstall if you want to try again.
Logging can be found by typing: journalctl -lfu signaling

root@cloud01:~# journalctl -lfu signaling
-- Logs begin at Fri 2020-08-28 16:49:02 CEST. --
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557131 mcu_janus.go:315: Created Janus session 3958446495390358
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557345 mcu_janus.go:322: Created Janus handle 5364016050721136
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557353 main.go:199: Using MCU janus at ws://127.0.0.1:8188
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557361 hub.go:283: Using a timeout of 10s for MCU requests
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557379 backend_server.go:94: Using configured TURN API key
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557385 backend_server.go:95: Using configured shared TURN secret
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557389 backend_server.go:97: Adding "turn:cloud01.MyDomain.net:3478?transport=tcp" as TURN server
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557393 backend_server.go:97: Adding "turn:cloud01.MyDomain.net:3478?transport=udp" as TURN server
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557397 backend_server.go:104: No IPs configured for the stats endpoint, only allowing access from 127.0.0.                                                                                             1
Aug 28 19:01:09 cloud01.MyDomain.net signaling[11911]: 2020/08/28 19:01:09.557484 main.go:274: Listening on 127.0.0.1:8081

Sorry for my bad english…

Greetings, Lars

Hi @Quickly71

Bugs are reported on Github, but I may help you here as well.

Which OS are you running, and what version? Please post the output of lsb_release -a. Also, are you running this on your own server that you setup, or is this the Nextcoud VM?

Thanks!

Hi enoch85.
Did not expect an answer so quickly! THX!

I have installed the OS completely new. Only set the PublicKey and then executed the first NC-Script. I have no further apps installed.
Then…

  • Theming" deactivated (imagick message)
  • Shutdown + VM Backup
  • Login as “root”
  • Same error again.

Logs

root@cloud01:~# journalctl -lfu signaling
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.479961 mcu_janus.go:315: Created Janus session 2563739054891558
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480670 mcu_janus.go:322: Created Janus handle 2289917541648874
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480701 main.go:199: Using MCU janus at ws://127.0.0.1:8188
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480717 hub.go:283: Using a timeout of 10s for MCU requests
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480735 backend_server.go:94: Using configured TURN API key
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480743 backend_server.go:95: Using configured shared TURN secret
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480749 backend_server.go:97: Adding "turn:cloud01.MyDomain.net:3478?transport=tcp" as TURN server
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480754 backend_server.go:97: Adding "turn:cloud01.MyDomain.net:3478?transport=udp" as TURN server
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480760 backend_server.go:104: No IPs configured for the stats endpoint, only allowing access from 127.0.0.1
Aug 29 10:21:04 cloud01.MyDomain.net signaling[7853]: 2020/08/29 10:21:04.480897 main.go:274: Listening on 127.0.0.1:8081

root@cloud01:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.1 LTS
Release:        20.04
Codename:       focal
NextCloud: 19.x - from Script

Hi enoch85.
At this time is only a Testing NextCloud.
If you whant, you can have Access to the system. If it helps you.
Then send me a private message.

@Quickly71

If you try to access the domain you use for Talk, what does it say?

http://talk01.MyDomain.net >> https://talk01.MyDomain.net

Hi there! :) If you see this page, the Apache2 proxy for Talk Signaling Server is up and running.

And Let´s Encrypt is Ok. Save Site

Hi, i had the same problem as you.
What i did is just adding talk.example.com to my /etc/hosts file.

127.0.1.1 talk.example.com talk

1 Like

Well, that’s strange.

What does the Signaling server say in Nextcloud Settings --> Talk?

Aah, that might be it!

@szaimen Maybe we should add that in the script as well?

Rock´n Roll! That´s it. :ok_hand:

nano /etc/hosts

127.0.1.1       talk01.MyDomain.net       talk01

Reinstall Talk + Signaling-Server

Not yet tested live. Installation however completed.

Thanks a lot!

2 Likes

We set the /etc/hosts value when you run the Let’s Encrypt script, so my question is, did you run that before you ran the Talk script or not?

If yes, it seems like we need to set it for the Talk script as well.

Yes, I listed the Let’s Encrypt directly during the installation. So before the Talk-Script.
Can/should I install Talk again? Or just run the Let’s Encrtypt again?

What’s the output of cat /etc/hosts?