Nextcloud talk not working audio

my own server:
debian 9
php 7.4.7 (https)
i7
24GB ram

running behind a fortigate 60E

The problem I have is that calls outside the local network, be it audio or video, take a long time to establish and the video rarely works, audio calls never worked. I don’t use STUN server

So a STUN server is provided by default and should be kept.
If connections fail, you need to consider getting a TURN server.

There is nothing that can be done to workaround it.

Can you recommend a turn installer for debian? I have never installed one

If a TURN server is needed (e.g. attendees behind firewalls) it will be busy, use a standalone server.

Google coturn debian

use this tutorial:
https://nextcloud-talk.readthedocs.io/en/latest/TURN/

Configure everything, when I do the test it gives me this: (I assume the stun works) if it is correct, I can’t get the turn to work, I don’t know how to test it.

Here is what I see in Talk configuration under Nextcloud 19

Where does your come from?

After installing the STUN and TURN servers on my server, I changed them, the STUN responds well but the TURN does not

on this website I test STUN and it gives me OK but I don’t know how to test TURN
https://webrtc.github.io/samples/src/content/peerconnection/trickle-ice/

That’s the way I use it…

Is your STUN/TURN server SSL’d?
Does it run with Nextcloud on the same server?

Yes, same server and SSL

Hmmm… I run a standalone one…

Could you show me how you got the turnserver.conf?

I do not think it makes a difference that it is all on the same server, no one is using it, only I am testing, it has no traffic. The tutorial is not very difficult either and I don’t know why the STUN works and not the TURN.

And if I do not put any server and leave everything as default, calls work 2 or 3 times and then stop working

If I delete all commented (#) out lines, I’m left with this


listening-port=3478
tls-listening-port=443

fingerprint

use-auth-secret

static-auth-secret=***********

realm=example.com

total-quota=100

bps-capacity=0

stale-nonce

no-tlsv1
no-tlsv1_1


I have it the same, but for some reason sometimes the audio calls work and sometimes they don’t, the same happens to me with the video, sometimes it calls quickly and sometimes waiting a user for 2 or 3 or 4 minutes without connecting.

That sounds like a network issue…
Do the problem happen to the same users? All the users at times?
Where do the users come from? Local network? From behind NAT/firewalls?

Does it happen only when running Talk or with any communication with the NC server?

Try - just for testing - removing your Fortigate box from the chain…

I am only using 2 users since we installed the service a few days ago, it happens to me with 2 users from different networks via wifi.
The server is internal and a fortigate acts as NAT.
It only happens with the talk, the strange thing is that sometimes the calls are connected without problems, they work barbarously and at times they do not communicate neither by audio nor by video.
If I want to send the call from the PC sometimes it gives the TURN (see image) server error, but I can’t get it to work, I don’t have a way to test it.

Thanks for helping me, I really appreciate it.