Nextcloud Talk ios/app : Access forbidden / CSRF Check failed

When trying to launch the Nextcloud Talk iOS app , I get Access forbidden what ever the username I use. However the same username/password works from the nextcloud login page!

Nothing in the log.

Last, I would consider this as a bug/issue, there is no way to get out of this error page. You have to kill the iOS/app in order to re-start the login !

Hi @Pipiche ,
are you using username/password or app-token login from the iOS app?
Also, that users you are trying , are they local users (created directly in NC) or SAML/LDAP users?

Thanks. It worked with app-token !

The user is a local user created directly in NC

Kind regards

Happy to hear that it worked with app-token, but you should also be able to login with username/password.
At the end, when you login with username/password from the app, NC generates an app-token for your Talk iOS app in the background.

i have the same problem with ios-talk app, also with app-token.
All my users have usernames like email address and login with ios-talk app failed:

:“core”,“method”:“GET”,“url”:"/ocs/v2.php/apps/spreed/api/v1/room",“message”:“Login failed: ‘’ (Remote IP: ‘2003:aaaa:13e7:6800:f857:54f0:b764:aaaa’)”,“userAgent”:“Mozilla/5.0 (iOS) Nextcloud-Talk v1.1.0”,“version”:“”}

I think the problem is that “@” in username is sendings as “%40”, i see the ‘’ also as auth-user in apache access.log .
Login and use of talk-app with browser works without any problems.

The email issue was solved in version 1.2.0 of Nextcloud Talk iOS app.

Thanks, it works now!

I have the same problem with Ios crsf check failed and it works fir android

I have the same error. I’m not able to reauthenticate in IOs App nether by user login nor App-Token.

I found an error in my log when trying to authenticate:
Could not find resource vendor/strengthify/jquery.strengthify.min.js to load

Seems like this will be fixed in 15.0.3

Hi , I solved it from my side ,
Are you using proxy ? Or load balancer ?

Could you describe how you fixed the issue? I’ ve got the same problem with Nextcloud sitting behind an NGING reverse proxy.

Quick follow up. I found this great workaround from @zvyezdan. Works for me.

you need to add in the config.php file the below lines
‘forcessl’ => true,
‘overwriteprotocol’ => ‘https’,

I think you need to add
‘forcessl’ => true,
‘overwriteprotocol’ => ‘https’,

1 Like

I’m experiencing exactly the same problem and tried your hint, unfortunately with no change on the problem.

I’m running NC15 behind a nginx reverse proxy which is enforcing SSL

I have the same Problem and only with the iOS app. With Android app from playstore I haven’t this issue. I am able to call via Nextcloud with safari on iOS, but not with the iOS app.

I can’t log in via username and password and also not via username and app token. There is no link to something about like „log in via the old method“.

By the way I am able to log in with the Nextcloud files app. The login is only not possible with the Nextcloud iOS app. I installed Nextcloud with docker-compose and I used this brilliant example for the installation:

Ok found the solution here:

It worked my server. I got the Access forbidden invalid request error when I wanted to enter on the phone nc app. I add this 2 line nextcloud config and worked. Thank you

Yes, this also helped me.

I don’t know why this is still not fixed as I would assume many self hosted NC will use reverse proxies.

Thank you!