Nextcloud stops working after enabling HTTPS on snap install


I’ve installed Nextcloud on a cloud VM using the snap method and all the installation seemed to work well until I enabled HTTPS with Let’s encrypt. After that, I simply cannot access Nextcloud web interface anymore. If I disable it, it works. Enable again, can’t access… Well, I think you understand…

I didn’t receive any errors during the certificate installation.

Nextcloud version: 27.0.2
Operating system and version: Ubuntu 22.04.3
Apache or nginx version: Apache provided by the snap
PHP version: PHP provided by the snap

I could not find anything useful in the logs, but I can happily provide any you find useful.


Little more details would be helpful to troubleshoot.

  1. Please mention the command you have used for Let’s Encrypt
  2. Are you using domain or sub-domain for this action?
  3. Have you checked and ensured both ports 80/443 are public from your cloud provider network firewall and from your OS Level Firewall to accept incoming connections?
  4. Have you tried to access the web interface via a different browser after enabling the SSL? (Sometimes clearing cache helps too)


The command I used to enable let’s encrypt was nextcloud.enable-https lets-encrypt.

I’m using a nextcloud subdomain already configured to point to the fixed IP in the cloud.
As far as I know, I have opened both the cloud provider firewall and OS ports for the incoming connections. This is the configuration for the cloud provider firewall. It’s the same as port 80 to port 443 and since port 80 works fine once HTTPS is disabled, I believe the problem is not with it.

Yes, I have tried accessing the web interface with a different browser but it also doesn’t work…

Thanks, for the help.