Nextcloud SNAP suddenly no longer starts

Nextcloud version (eg, 20.0.5): 18.0.12snap1 "SNAP Package"
Operating system and version (eg, Ubuntu 20.04): Ubuntu 19.10
Apache or nginx version (eg, Apache 2.4.25): Apache

The issue:
This system has been in operation for a long time, and suddenly no longer correctly loads. I cannot access any of the Web GUI, etc. But when I run the following command in the hosts terminal…:

snap logs nextcloud
Starting MySQL...
[ERROR] --initialize specified but the data directory has files in it. Aborting
[ERROR] Aborting
Starting MySQL
* The server quit without updating PID file (/tmp/pids/
Waiting for MySQL...

Does anyone have an idea how to correct this, without losing the data? I believe the reason is the above error preventing MySQL from starting, and thus the entire snap fails to start.

I was able to get it to work again by issuing the following command:

snap revert nextcloud

Which is supposed to revert the snap instance to the prior snap package it updated from. Since I previously had tried restoring the VM that this SNAP package run on, and within 24 hours, the issue returned, it would seem that the issue is the Snap package is installing something that breaks the current installation. I plan on making backups of this NC instance’s data, and importing it to a new one with a more updated version NC.

I’ve also added

to /etc/hosts in order to break the update cycle so this issue is halted till the move.