Nextcloud snap installation backup not working anymore

Nextcloud version: (installed via snap)
Operating system and version: Ubuntu Server 20.04
Apache version: unsure, where can I find this info?
PHP version: 8.2.15

When I run the nextcloud.export command it will export the apps, database and config.

When it comes to backup the data directory it takes one second and it says “100%” without saving any data.

This is the output from my command line after running nextcloud.export:

WARNING: This functionality is still experimental and under
development, use at your own risk. Note that the CLI interface is
unstable, so beware if using from within scripts.

Enabling maintenance mode... done
Exporting apps...
        847.61M 100%   28.75MB/s    0:00:28 (xfr#6079, to-chk=0/6919)
Exporting database...
Exporting config...
Exporting data...
            542 100%    0.00kB/s    0:00:00 (xfr#2, to-chk=0/3)

Successfully exported /var/snap/nextcloud/common/backups/20240421-204532
Disabling maintenance mode... done

I am not sure what to do or what I did wrong (or if it’s even my fault).

Steps to replicate it:

  • run nextcloud.export as sudo user

My config.php file:

$CONFIG = array (
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/snap/nextcloud/current/htdocs/apps',
      'url' => '/apps',
      'writable' => false,
    1 =>
    array (
      'path' => '/var/snap/nextcloud/current/nextcloud/extra-apps',
      'url' => '/extra-apps',
      'writable' => true,
  'supportedDatabases' =>
  array (
    0 => 'mysql',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/tmp/sockets/redis.sock',
    'port' => 0,
  'log_type' => 'file',
  'logfile' => '/var/snap/nextcloud/current/logs/nextcloud.log',
  'logfilemode' => 416,
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' =>
  array (
    0 => '',
    1 => 'xxx',
  'datadirectory' => '/mnt/cloud/data',
  'skeletonDirectory' => '/mnt/cloud/skeleton',
  'default_phone_region' => 'AT',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:/tmp/sockets/mysql.sock',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'xxx',
  'installed' => true,
  'maintenance' => false,
  'loglevel' => 2,

Beside the backup problem my ‘overwrite.cli.url’ is set to and I have no clue why as I don’t even know which device uses this IP address.

The backup directory is created via symlink (NFS share on my NAS) and always worked normally, but since a few days it’s not working anymore…I need advice please, thank you!


Just asking, do you have enough space in that same disc to take the backup?

Full backup meaning full size replication of your user data too.



yes I do. My backup directory is created via symlink on my NAS which has plenty of TB left.