Nextcloud Snap - E-mail notifications URLs

Hi All

I have looked around and was unable to find a solution. I suspect there might not be one but hoping for some assistance.

OS: Ubuntu 20.04.5 LTS (Physical Server)
Nextcloud Type: SNAP
Nextcloud Version: 25.0.3

Notification images are not displaying as the URL for the image refers “localhost” and not my FQDN. Same goes for any links in these notification e-mails.

Accessing nextcloud using my FQDN works perfectly as well as calender syncs from CalDav. SSL certificates working fine (using Let’s Encrypt). Trusted domains contains my FQDN (and also localhost).
It seems that with non-snap installs, I can modify the overwrite.cli option in the config.php file but from what I understand, I cannot do this on a snap install.

Is there an official way around it? Should I cross my fingers, remove “localhost” from my trusted domains and see what happens?

Any advise would be appreciated. Surely many people will be stuck in the same situation unless, of course, I missed the solution to this somewhere.

Thank you in advance.

Best Regards,


Welcome to the community.

The source URL is dynamic. Are logging in with to your FQDN name in the browser?

I always use the FQDN, but in the notification e-mails if I look at the source of these mails, images and links are linked to localhost and not my FQDN.

Anyone have any ideas?