NextCloud SNAP and External Read Only Share

Hi all, this is my first NextCloud install.

I have NextCloud installed on a Ubuntu 20 machine via SNAP.

NextCloud is working 100% ok.

I have some pictures on a remote machine I want to serve with NextCloud without facing the risk that these pictures gets deleted or edited by NextCloud so I setup a samba server on a remote machine with a read only share being served so I can enforce that no samba client will be able to delete or edit my files even if it gets compromised.

Then I mapped this samba share in my NextCloud machine so these pictures are available at /media/pictures.

I got this working adding a line to my /etc/fstab:
// /media/pictures cifs user=xxxx,password=xxx,_netdev,file_mode=0770,dir_mode=0770 0 0

So far so good. All files can be reached from NextCloud server command line.

Then I ran
sudo snap connect nextcloud:removable-media

Then I went to NextCloud / Settings / Administration / External Storage and added a new item as follows:
Folder name: Pics / External Storage: Local / Authenthication: none / Configuration: /media/pictures / Available to: my user.

So I got the green tick.

Now the folder shows up on my Files section on NextCloud but when I click on that no files or subdirectories from my folder shows. All empty.

I tried mounting my share forcing uid:1000/gid:1000 and nothing changed
// /media/pictures cifs user=xxxx,password=xxx,_netdev,uid=1000,gid=1000,forceuid,forcegid,file_mode=0770,dir_mode=0770 0 0

I also tried mouting my share forcing user and group to www-data and nothing changed either.
// /media/pictures cifs user=xxxx,password=xxx,_netdev,uid=www-data,gid=www-data,forceuid,forcegid,file_mode=0770,dir_mode=0770 0 0

What am I missing here? How to accomplish that?

kind regards