NextCloud SMS not working between server running NextCloud 13 and device running Android 7.0


#1

I recently installed NextCloud to my own server and most things are working (Contact Sync, Calendar Sync, File Sync, etc) and one of the things that is not working is either the NextCloud Phone Sync app for NextCloud or the Android app NextCloud SMS.

By not working, I mean that the NextCloud SMS Android app keeps saying “Syncing SMS” at various points via Android Notifications but nothing ever appears in the NextCloud Phone Sync App.

My server has the following software:
OS: Gentoo Linux with Profile 2017.0
Web Server: Apache v2.4.27-r1
Database: mariadb v10.1.29
PHP Version is 7.1.13

My phone an LG V20 running Android 7.0.

For most of the problems I’ve had with NextCloud Apps, I could solve them myself but this one is tricky as I’m sure where to look to see what went wrong.

I saw a GitHub issue that mentioned that PHP 7 or Android 7.0 could have changes that make it no longer work but I’m not sure if those were still current issues or even really understand what the incompatibility would be with those versions.


#2

You could try to reinitialize the synchronization cursor in the Android app for your Nextcloud SMS account: https://github.com/nextcloud/ocsms/issues/215

I had the problem that every time a new SMS came in I had to do this to get it synced. The bug is still not resolved.


#3

I have tried that at least 3 times now and it still is not syncing messages.


#4

Huh, I got it to work.
I uninstalled the Android app, reinstalled it, added my NextCloud account again, then I tapped the “App Info and permissions” item on the menu, selected the permissions “Contacts”, “Phone” and “SMS” and then did a sync.

I thought I had done the permissions before but I’m not sure what else would have changed about the app to make it work.

I can say regardless that the way this app handles Android Permissions is weird. It should just ask in the app for the permissions it needs instead of leaving the user to figure out to how to set the permissions on their own.

No other Android app I have used just expects me to set the permissions it needs for it without even telling me that they need to be set so it’s a bit weird that the ‘NextCloud SMS’ app does.

As least the version from F-Droid but I would assume it was the same as the Google Play Store version.


#5

I did the same (uninstall appli, re-install it, set account… reinitialize the sync cursor) but still no sync ;

NextCloudPi 13.0.2
ocsms : Phone Sync 1.12.2 installed manually from github

Phone Wiko Lenny 3 Androïd 6.0

It was working on another instance of Nextcloud on a RaspBerry PI 3.
I moved to nextcloudpi distribution because of better system optimization.