Nextcloud signaling version incomapatible

So i setup a High Performance Backend according to the tutorial at:
https://markus-blog.de/index.php/2020/07/30/how-to-install-nextcloud-talk-high-performance-backend-with-stun-turnserver-on-ubuntu/

I have all settings configured correct but now the signaling server reports as being incompatible with my version of Talk. the version of the signaling server reports as:
0dcb9f6b2d9629ca4e41e78cd7aa61ff5d80f714

This is what it says in the Talk settings section under High Performance Backend
Error: Running version: 0dcb9f6b2d9629ca4e41e78cd7aa61ff5d80f714; Server needs to be updated to be compatible with this version of Talk

And this when i go to https://communicate.kraaijvanger.nl/standalone-signaling/api/v1/welcome
{“nextcloud-spreed-signaling”:“Welcome”,“version”:“0dcb9f6b2d9629ca4e41e78cd7aa61ff5d80f714”}

And when i do signaling -version it says
nextcloud-spreed-signaling version 0dcb9f6b2d9629ca4e41e78cd7aa61ff5d80f714/gol.15

Any help would be appreciated.

Server:
Ubuntu 20.04.1
Nextcloud 23.0.4
PHP 7.4.10
PostgreSQL 10.21

Hey,

the version in this case refers to a commit from august 2020 (Unregister / remove subscriber if reconnection didn't work. · strukturag/nextcloud-spreed-signaling@0dcb9f6 · GitHub).
The latest commit is a few hours old. Did you clone the repository just yet or is this a old clone?
When you enter /opt/nextcloud-spreed-signaling/ can you run git status and check if you’re using the master branch?

You can also try a released version: Releases · strukturag/nextcloud-spreed-signaling · GitHub

Hi SysKeeper,
Thanks for the quick reply.

I did this exact command:

git clone https://github.com/strukturag/nextcloud-spreed-signaling.git

The output of git status from the /opt/nextcloud-spreed-signaling/ directory is:

Your branche is up to date with ‘origin/master’

Changes not staged for commit:
(use “git add …” to update what will be committed)
(use “git restore …” to discard changes in working directory)
modified: go.mod

Untracked files:
(use “git add …” to include what will be committed)
tat -tulpen | grep 8080

no changes added to commit (use “git add” and/or “git commit -a”)

Hm. Can you run git log -n 1 to see the last commit? I just did a clone and the output looks like this

$ git log -n 1
commit 79532954da7bb5c255deb6dac03d6190baa82f17 (HEAD -> master, origin/master,                                                                                                              origin/HEAD)
Author: Joachim Bauch <bauch@struktur.de>
Date:   Wed Jun 15 09:12:21 2022 +0200

    readme: Update link to documentation.

Another thing would be to do a git pull to make sure you’re really up to date, in my case that results in

$ git pull
Already up to date.

After the git pull command i get the following when i do git log -n 1:

commit 79532954da7bb5c255deb6dac03d6190baa82f17 (HEAD -> master, origin/master,                                                                                                              origin/HEAD)
Author: Joachim Bauch <bauch@struktur.de>
Date:   Wed Jun 15 09:12:21 2022 +0200

Which is exactly the same as you get. Also after another git pull i also get already up to date.

However the error in the Nextcloud Talk settings is still the exact same as well as the output of signaling -version etc.

After pulling the latest version you need to rebuild the signaling server (see step 5 from your linked howto)

Yeah i thought of that but when i did make build i got the output below.
I update golang to 1.17 because of that but that didn’t change anything.

mkdir -p "/opt/nextcloud-spreed-signaling/bin"
/usr/bin/go build -ldflags '-X main.version=79532954da7bb5c255deb6dac03d6190baa82f17' -o "/opt/next
c loud-spreed-s igna ling/bin"/s igna ling . /server/ ...
# go.etcd.io/etcd/client/pkg/v3/tlsutil
/root/go/pkg/mod/go.etcd.io/etcd/client/pkg/v3@v3.5.4/tlsutil/cipher_suites.go:22:20: undefined: tls
.CipherSuites
/root/go/pkg/mod/go.etcd.io/etcd/client/pkg/v3@v3.5.4/tlsutil/cipher_suites.go:27:20: undefined: tls
.InsecureCipherSuites
/root/go/pkg/mod/go.etcd.io/etcd/client/pkg/v3@v3.5.4/tlsutil/cipher_suites.go:34:10: undefined: tls
.TLS_ECDHE_RSA_MITH _CHACHA20_POLY1305_SHA256
/root/go/pkg/mod/go.etcd.io/etcd/client/pkg/v3@v3.5.4/tlsutil/cipher_suites.go:36:10: undefined: tls
.TLS_ECDHE_ECDSA_MITH _CHACHA 2 0 _POLY1305_SHA256
note: module requires Go 1.16
# github.com/golang-jwt/jwt
/root/go/pkg/mod/github.com/golang-jwt/jwt@v3.2.2+incompatible/ecdsa.go:135:4: r.FillBytes undefined
(type *big. Int has no field or method F illBytes)
/root/go/pkg/mod/github.com/golang-jwt/jwt@v3.2.2+incompatible/ecdsa.go:136:4: s.FillBytes undefined
(type *big. Int has no field or method F illBytes)
# golang.org/x/net/http2
/root/go/pkg/mod/golang.org/x/net@v0.0.0-20211112202133-69e39bad7dc2/http2/transport.go:417:45: unde
fined: os.ErrDeadlineExceeded
note: module requires Go 1.17
# github.com/nats-io/nats.go
/root/go/pkg/mod/github.com/nats-io/nats.go@vl.16.0/nats.go:1849:23: nc.current.url.Redacted undefin
ed (type *Url.URL has no field or method Redacted)
note: module requires Go 1.16
make: *** [Makefile: 110: server J Error 2

As the build process complains about required Go version, I guess the update to golang 1.17 didn’t succeed or it still uses the wrong golang?

Hi SysKeeper,

Thanks for the help.
I managed to solve this.
i now get: OK: Running version: 79532954da7bb5c255deb6dac03d6190baa82f17
Even after installing go 1.17 it was still using 1.13.
After apt-get remove golang-1.13 the system automatically installed version1.18.
With that the make build command succeeded succesfully.

Thanks very much for pointing me in the right direction.

1 Like