Nextcloud returns to page "create admin account" after update

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2):
Operating system and version (eg, Ubuntu 17.04): hosted by - so some linux I suppose
Apache or nginx version (eg, Apache 2.4.25): n/a
PHP version (eg, 7.1): 7.2

The issue you are facing:

Hi all,

after having updated nextcloud to the latest version, it “doesn’t work” anymore.
“Doesn’t work” as in:
When I go to the landing page, I’m asked to create an admin account as well as to provide the details for the database.
Also, my clients accessing the cloud apparently have lost their connections.
The softclient on my Windows Machine tells me, it cannot connect due to “unknown protocol”.

When I try to create a new admin, it tells me my username already exists, or rather “access denied”

So, how do I handle this situation?
How can I login again?
Or do you need further information to be able to help?

Thanks and kind regards,

Is this the first time you’ve seen this error? : Y

Steps to replicate it: I hope, this cannot be replicated in future …

The output of your Nextcloud log in Admin > Logging:

I'm sorry, but for reasons given above currently I cannot access "Admin > Logging"

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ocksu43ez5k3',
  'passwordsalt' => 'SALT',
  'secret' => 'SECRET',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/path/to/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'DB3679991',
  'dbhost' => 'ZZZZZ',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'XXXXX',
  'dbpassword' => 'YYYYY',

The output of your Apache/nginx/system log in /var/log/____:

It's hosted ... I don't have access to this path - sorry ...

Anyone any ideas?

Thanks and kind regards,


Due to all my files being “secured” on my hard drive, I tried to check what would happen, if I just enter some random admin account - as if creating a new one.

Result: Some error page “internal server error / 500”.
Then, Nextcloud returned to the standard login page and now I can access my files again …

So, never mind and thanks for reading … yet, a strange mistake …

Thanks and kind regards,

I guess, I figured out, what happend:

The update replaced my modified “config.php” with a more or less generic one:
My entries for “tempdirectory” has been gone …

Replacing the config.php apparently caused this behaviour …

So, question: can we make it so, that the next update does not touch the config.php?

Thanks and kind regards,

Ok, apparently this issue has NOT been solved …

and in all honesty: I’m PISSED down to the core!

Aside from my next cloud apparently having updated WITHOUT asking me beforehand, what was the result?

The SAME bullshit that happened as decribed above…

However, NOW the solution I figured out for the error above does not work any more!
Instead, replacing the config.php with the backupped one leads to a HTTP ERROR 500 …

Now what … ??

Thanks an kind regards,

I never heard that nc updated without asking.
Did you install that by some package manager from your webhoster?

Never heared of that either.
However, looking at the filesystem I can see files with last access date = yesterday.
Also, the config.php is almost empty …

Ergo: SOMETHING did happen - whether it was an update or something else …

And, no, I installed my nextcloud manually (i.e. via download from here, upload to my webspace there, run install script and so on …)

Edit: I don’t get it … as a workaround, this time creating a new admin account worked. Even my user account still exists …
Yet: Getting this “finalize your installation” screen always makes me incredibly nervous! I don’t want some random dude taking over my cloud!

Kind regards,

Hi Kai,

I just saw your initial post and noticed you posted sensitive data like password salt and secret. So, unfortunately, you made it easier for an attacker to steal data in case he gets access to your server somehow. Salts and secrets should never be posted online.

Regarding your problem. If this issue happened twice already, I’d really check my system earlier.
Nextcloud does not update automatically. And if it is not Strato doing this for you, there must either be a scheduled job (cron job for your user, for root or for the web user setup)?

Whatever the update process is triggered by, that update process has a problem and is probably setup incorrectly. The web updater by nextcloud for example moves the whole NC directory somewhere else (backup), extracts the new version previously downloaded and moves the backuped config.php back to the freshly extracted folder.

The update process used on your server is either forgetting this step or is not allowed to perform this step.
However, this is not a problem in the Nextcloud software itself. This is rather a configuration issue or whatever issue on your system.
Of course the community will try to help you, but we need you to check your system for the process triggering the update.

Hi Schmu,

thanks for the reply!

I was not aware that password salt and secret are data someone can actually work with :-/

Is there a chance I can change the value for those?

Also, you wrote:

Ok, so … Strato is definetly not doing it. Is there a chance I can check for cron jobs within nextcloud? Because: I cannot remember having a cron job set up within Strato’s interface …


This sounds plausible!
What permissions do I need to check in order to verify this behaviour?

Many thanks and kind regards,


I don’t know that right now and need to check how this is possible. I’ll let you know, when I found something. Maybe you find something yourself in the meantime.

I’m not sure which users you have access to and so on, but in general you can check for cronjobs with:
crontab -l

As root user you could check for jobs for all relevant users:
crontab -l (for root himself)
crontab -l -u <web server user> (web server user like www-data or http)
crontab -l -u <user you login with>

You could provide the output of
ls -la <path/to/nextcloud-install-dir>
ls -la <nc-datadir/updater-ocksu43ez5k3

Uhmm … it’s a Strato webhosting server … to which I do not have any root access …
Also, no access to a shell …
Is there a way to run those commandlets with, say, a script and make the script create the output needed?

I don’t know anything about Strato. No idea what you can do via web GUI and so on.
If you don’t have an option on the web GUI to create a cronjob or any other kind of automatic tasks, then I don’t think you created one by mistake.
In my opinion it is best to ask Strato support. They better understand what happens on their servers.

Sounds like a plan …

Thanks :slight_smile: