Nextcloud reagiert extreeeeem langsam

Hallo zusammen,
seit einiger Zeit, ich vermute nach einem PHP Update, reagiert Nextcloud extrem langsam. Sowohl das Webinterface, als auch der Clientzugriff dauert gefühlt ewig bis etwas passiert nach einem Klick.
Könnt ihr mir einen Tip geben, wie ich bei der Fehlersuche am besten vorgehen kann?
Danke schonmal im Voraus.

Gruß

Michael

Nexcloud 16.0.5 auf Ubuntu 16.04.2 und Apache
Firefox, Chrome; Windows Client 2.5.3, 2.6

Hallo
Auf was läuft deine cloud :wink:
Und hast du die alte php.ini oder die neue php.ini bearbeitet ?
wenn du als Admin in die nextcloud einstellungen gehst und links auf Übersicht was sagt er da ?

fg

Danke schonmal für deine Antwort. Also die Umgebung hab ich oben in der letzten Zeile geschrieben.
Die Frage ist jetzt, welche php.ini ich bearbeiten muss und wie!?
Also unter /etc/apache2/mods-enabled/ hab ich u.a. php7.3.conf bzw php7.3.load stehen.
Wenn ich mir die verwendete php.ini anzeigen will per php -i | grep php.ini bekommen ich

Configuration File (php.ini) Path => /etc/php/7.3/cli*
Loaded Configuration File => /etc/php/7.3/cli/php.ini*

Somit müsste es ja diese sein!? Was aber genau muss in der ini alles stehen?

Achso, bei den Sicherheits- und Einrichtungswarnungen steh:
Es gibt einige Warnungen bei Deiner Systemkonfiguration.

  • MySQL wird als Datenbank verwendet, unterstützt jedoch keine 4-Byte-Zeichen. Um beispielsweise 4-Byte-Zeichen (wie Emojis) ohne Probleme mit Dateinamen oder Kommentaren verarbeiten zu können, wird empfohlen, die 4-Byte-Unterstützung in MySQL zu aktivieren. Für weitere Details lesen bitte die Dokumentationsseite hierzu.

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/caldav” aufzulösen. Weitere Informationen findest Du in der Dokumentation.

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/carddav” aufzulösen. Weitere Informationen findest Du in der Dokumentation.

  • Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der Leistungsfähigkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen findest Du in der Dokumentation.

Wobei mir ersteres Wurscht ist, ob ich Smileys einfügen kann oder nicht. Die well-known Sachen hab ich hier im Forum schonmal versucht zu klären, bekomme ich nicht hin, ist aber in diesem Zusammenhang auch nicht wirchtig. Und der mem-cache ist laut Doku auch nicht zwingend erfordelich, bzw den Hinweis hatte ich auch schn vor dem Geschwindigkeitsverlust

Tja da musst du noch rann ich rate dir an bearbeite die

/etc/php/7.3/apache2/php.ini

Oder geh in die console als root

und feuere das rein

sed -i ‘s#memory_limit = 128M#memory_limit = 512M#’ /etc/php/7.3/apache2/php.ini

“ENTER” und das noch

sed -i ‘s#upload_max_filesize = 2M#upload_max_filesize = 999G#’ /etc/php/7.3/apache2/php.ini

“ENTER” und das noch

sed -i ‘s#;opcache.enable=1#opcache.enable=1#’ /etc/php/7.3/apache2/php.ini

“ENTER” und das noch

sed -i ‘s#;opcache.enable_cli=0#opcache.enable_cli=1#’ /etc/php/7.3/apache2/php.ini

“ENTER” und das noch

sed -i ‘s#;opcache.interned_strings_buffer=8#opcache.interned_strings_buffer=8#’ /etc/php/7.3/apache2/php.ini

“ENTER” und das noch

sed -i ‘s#;opcache.max_accelerated_files=10000#opcache.max_accelerated_files=10000#’ /etc/php/7.3/apache2/php.ini

“ENTER” und das noch

sed -i ‘s#;opcache.memory_consumption=128#opcache.memory_consumption=128#’ /etc/php/7.3/apache2/php.ini

“ENTER” und das noch

sed -i ‘s#;opcache.save_comments=1#opcache.save_comments=1#’ /etc/php/7.3/apache2/php.ini

“ENTER” und das noch

sed -i ‘s#;opcache.revalidate_freq=2#opcache.revalidate_freq=1#’ /etc/php/7.3/apache2/php.ini

“ENTER” :wink: sollte ohne fehler durchlaufen

danach in der console noch

sudo mysql -u root “ENTER”
ALTER DATABASE cloud CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci; “ENTER”
EXIT; “ENTER”

dann das noch und ich hoffe deine cloud ligt in www und heist nextcloud ansonsten anpassen :wink:

sudo -u www-data php /var/www/nextcloud/occ config:system:set mysql.utf8mb4 --type boolean --value=“true”

“ENTER” das selbe noch mal anpassen und senden in der console

sudo -u www-data php /var/www/nextcloud/occ maintenance:repair “ENTER”

und dann das ganze neu starten ^^

Uiuiuiuiui Ok, vielen Dank schonmal dafür!!!
Ich werde das nächste Woche mal angehen

Also bei dem Befehl hier:

bekomme ich ein

In SetConfig.php line 149:
Unable to parse value as boolean

zurück. Alles andere ist sauber durchgelaufen.

Ok was steht jetzt noch drin in der Sicherheits- und Einrichtungswarnungen ?

Noch das gleiche wie vorher, dafür aber dies hier zusätzlich:
Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • EXTRA_FILE
      • .rnd
      • ocs/.rnd

Raw output

Array
(
[core] => Array
(
[EXTRA_FILE] => Array
(
[.rnd] => Array
(
[expected] =>
[current] => 1d9d4f6ed320935ada349b182995c547e1677936b8f477fe62a107cf47f6af9a1be813d37908b2322b058ec4086c49650edee5f03876dc8ed8b122917b16f8e9
)

                [ocs/.rnd] => Array
                    (
                        [expected] => 
                        [current] => 2abafb2b83ed6a8ff1d346499d8fe46e6216c12fbd7dd7cc5112ee5b7edbf10e3ec442ece20af50dfedff3c0809e7d4decd659b2d6238649884c0bca5f673337
                    )

            )

    )

)

  • Einige Dateien haben die Integritätsprüfung nicht bestanden. Weiterführende Informationen befinden sich in unserer Dokumentation.

  • MySQL wird als Datenbank verwendet, unterstützt jedoch keine 4-Byte-Zeichen. Um beispielsweise 4-Byte-Zeichen (wie Emojis) ohne Probleme mit Dateinamen oder Kommentaren verarbeiten zu können, wird empfohlen, die 4-Byte-Unterstützung in MySQL zu aktivieren. Für weitere Details lesen bitte die Dokumentationsseite hierzu.

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/caldav” aufzulösen. Weitere Informationen findest Du in der Dokumentation.

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/carddav” aufzulösen. Weitere Informationen findest Du in der Dokumentation.

  • Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der Leistungsfähigkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen findest Du in der Dokumentation.

der Punkt sollte weg sein

hier musst du noch den PHP-Memory-Cache konfigurieren
https://docs.nextcloud.com/server/13/admin_manual/configuration_server/caching_configuration.html

den müll hab ich auch nur mehr davon ^^
sind zwei dateies die da nicht hingehören
" .rnd" kigt im ordern der cloud löschen hat nur vor einem updat sinn da sie wieder kommen

ach ja

hier noch

die zum beheben