Nextcloud Raspberry Port Konflikt

Hallo,
seit einigen Wochen habe ich immer wieder das Problem, dass einen neustart des Raspberry’s auf dem Nextcloud läuft, der Apache Server nicht startet. Erst nachdem ich über den Befehl “fuser -k -n tcp 443” den Port freigegeben habe, kann ich den Apache Server wieder starten.
Was mich am meisten irritiert ist, dass es spontan aufgetreten ist und seitdem immer wieder. Vorher lief das mehrere Monate ohne Probleme und auch nach mehreren Neustarts ist der Server immer angesprungen.
Kann mir jemand helfen die Ursache zu finden?

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 1.47
Operating system and version (eg, Ubuntu 20.04): Raspbian 10
Apache or nginx version (eg, Apache 2.4.25): 2.4.38
PHP version (eg, 7.4): replace me

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):N

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Du könntest erst mal die Ursache ermitteln. Installiere mal lsof und zeig uns.

lsof -i 443
lsof |grep 443

Versuch die Anwendung los zu werden. Sie scheint ja nicht wirklich wichtig zu sein. :wink:

Hallo und danke für die Antwort.

Hier ist das Ergebnis von lsof -i 443:

lsof: unknown protocol name (43) in: -i 443
lsof 4.91
 latest revision: ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/
 latest FAQ: ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/FAQ
 latest man page: ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_man
 usage: [-?abhKlnNoOPRtUvVX] [+|-c c] [+|-d s] [+D D] [+|-E] [+|-e s] [+|-f[gG]]
 [-F [f]] [-g [s]] [-i [i]] [+|-L [l]] [+m [m]] [+|-M] [-o [o]] [-p s]
 [+|-r [t]] [-s [p:s]] [-S [t]] [-T [t]] [-u s] [+|-w] [-x [fl]] [--] [names]
Use the ``-h'' option to get more help information.

Scheint nicht so richtig zu sein, fehlt noch eine Installation?

Hallo @ehaeb

Versuche es mal als root, respektive mit sudo. Und eventuel noch mit einem Doppelpunkt vor dem 443.

sudo lsof -i :443

oder:

sudo netstat -ltnp | grep -w ':443'

Hallo,

mit dem : hat es geklappt. Hier das Ergebnis.

COMMAND   PID    USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
mongoose  497    root    4u  IPv4  13198      0t0  TCP *:https (LISTEN)
java     1202 openhab  330u  IPv6  31098      0t0  TCP openhabian.fritz.box:4821 

Kann mir jemand erklären wofür mongoose benötigt wird und warum das auf einmal den Port blockiert?

Ich tippe auf irgend ein Add-on für openHAB… Kenne mich damit nicht aus, habe aber einfach mal nach “openHAB” und “mongoose” gegoogelt und folgendes gefunden… https://github.com/mongoose-os-apps/sonoff-basic-openhab

Mann mann mann, wie wärs wenn du uns hier nicht raten lässt sondern mal dein gesamtes Setup und Serverumgebung verrätst.
Was läuft da noch alles auf dem Server?

@JimmyKater @ehaeb
Der Pi ist ein schönes Bastel-Projekt. Da kann man schnell was installieren und vergessen es wieder zu deinstallieren :wink: Wie @bb77 schreibt ist es wohl Mongoose, was installiert und nicht deinstalliert wurde bzw. leider auch auf Port 443 läuft und vor Nextcloud gestartet wird. Man könnte vielleicht nginx vorschalten. :wink:

https://github.com/cesanta/mongoose
https://en.wikipedia.org/wiki/Mongoose_(web_server)

Leider kenne ich die Anwendung nicht.
In der Dokumentation finde ich auch irgendwie nicht die Möglichkeit den Port irgendwie zu konfigurieren. Im Beispiel ist es im C-Code verdrahtet.

Fragen an @ehaeb:
Was hast du wirklich installiert?
Hast du irgendwo den Port 443 dafür konfiguriert?

OpenHAB hört wohl standardmässig auf Port 8080 und 8443, was aber angepasst werden kann. https://www.openhab.org/docs/installation/security.html Ob es mongoose als embedded Webserver nutzt, weiss ich nicht. Entweder das oder der kam zusätzlich mit einer Erweiterung von openHAB.

OT

Du bist auch mit allen Wassern gewaschen.

Ausser Nextcloud und OpenHAB läuft nichts mehr auf dem Raspberry 4.

Ja aber OpenHAB belegt bei dir offensichtlich Port 443. Du musst entweder OpenHAB oder Nextcloud auf einem anderen Port laufen lassen. Ich würde empfehlen OpenHAB auf dessen Standardports (8080 und 8443) laufen zu lassen und ihn dann so zu nutzen. Oder du fügst einen weiteren VirtualHost mit einer Reverse Proxy Konfiguration zu deinem Apache hinzu, über den du dann OpenHAB via Port 443 aufrufen kannst.

Habe es gerade nochmal geprüft. Openhab läuft noch auf den standard Ports 8080 und 8443. Eventuell ist es wirklich ein nicht richtig entferntes Addon von openhab. Bei den aktiven Addons habe ich keins gefunden, dass auf dem 443 Port läuft.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.