Nextcloud Quota doesn't work with LDAP

Nextcloud version (14.0.6):
Operating system and version (Debian 9.8):
Apache or nginx version (Apache 2.4.25):
PHP version (eg, 7.0.33):

The issue you are facing:
I use the LDAP integration for my Nextcloud users and I’m using the Attribute nextcloudQuota to define the quota. This attribute reads for example “200 MB” (without the quotes)

However, NC never picks up this change.
I’ve changed the attribute days ago and it’s still 1 GB.

Is this the first time you’ve seen this error? (Y):

Steps to replicate it:

  1. Install NC 14.0.6
  2. Enable LDAP integration
  3. Go to advanced > special attributes and set the Quota Field to nextcloudQuota (or whatever your LDAP attribute is)
  4. See if something has changed after a while

You can speed up the sync speed to one hour (or less), so that you don’t have to wait one day:

sudo -u www-data php occ config:app:set user_ldap updateAttributeInterval --value=3600
Config value updateAttributeInterval for app user_ldap set to 3600

I grepped the nextcloud.log back and forth with different approaches - it doesn’t say anything about LDAP problems.

I know this is old, but i have the same problem. Did you find a solution to this?