Nextcloud problem in mobile phones

Steps to reproduce

  1. Fills fields with details
  2. Click on arrow login button
  3. Login into user’s account

Expected behaviour

  1. After a user fills the fields on the login form and click the arrow login button (icon) should react and redirect to the user file storage account.
  2. After the user redirects on his account, of the file storage, files and side nav bar should appear.

Actual behaviour
2. When someone is trying to login in the platform, can’t because the arrow login button won’t react on mobile browsers. I.E. i try, filling all the fields (username - password) and when i click on the arrow login button, it doesn’t react (like loading) instead of that, it is asking me to fill complete-fill the fields again (without removing the previous filled fields). Found solution on that (Look below at “A”)
3. Then after login session is correct i faced the problem that neither files and side nav bar won’t shows up (Look below at “B”) .
4. Even from these methods i tried to bring side nav bar, but the files aren’t loading or showing up (Look below at “C)”).

Conclution-Modifications: A) I found a solution on that, removing by the login.php on the code login form “disabled=“disabled”” code B)I tried and shown up the side nav bar adding at config.php code “‘asset-pipeline.enabled’ => true,”. C) The only method that files are showing on or the platform reacts as it should be, is just by connecting my mobile with wi-fi or by enable “data saver” mode i.e. on chrome > settings > data saver > on.

Can you provide:

  • Nextcloud version
  • New install or upgrade
  • Device used - can you replicate on others?
  • OS/browser version

I can’t replicate this at all, using 3 independent installs.

Yeah ofc, i 'm really sorry, i forgot to write those infos.
Well my…

Nextcloud version: 10
Installation: Fresh new installation
Device used: Galaxy S3 Neo & iPhone S6 Plus (but same on all)
OS/Browser: Android 4.4 (Chrome Last Updated) & iOS 9 (Safari Last Updated)

No problem here on Android 5.1.1 with Firefox 48 and NC 10, or Chrome on Linux using a minimum width browser window. Sounds like a blink/webkit thing to me. @Mihail_Llaftiu Do you have this problem on Desktop Chrome? What about if you make the window width small enough that NC displays the mobile version? If you do get this problem on a thin-width desktop Chrome browser, do you see any errors in the browser console?


@Bugsbane @JasonBayton i tried the inspect mode, using mobile devices mode, but that was working. So even in that case, propably the code recognise the user still as desktop mode. The problem is faced only on real mobile devices. Even if i had to enable the pipeline assets still files aren’t shown up. Any idea or help would really appreciate it!

Could you try using Firefox on Android, as this uses a non WebKit rendering engine and may give us a clue as to where the problem lies.

What’s unusual is that we’re not seeing other people with this problem, and yet you’re getting it on multiple platforms. It’s likely also worth filling an issue here

Hello @Bugsbane,

I checked every browser on android and ios platforms. Every browser it acts the same as the others, which means every browser face this problem. The solution is only by enable Wi-Fi so files and sidebar nav menu load - sync - shows up or by enabling i.e. at chrome “Data saver” mode or in UC broser “Speed Mode” in mozilla i couldn’t find something similar. My server is VPS, with Centos 6.8 and Plesk. The Vserver itself is dual core, ssd and 12gb of ram including the 100mbit/s connection port. MySQL, FastCGI, PHP > v5.6. The website is tested both as sub-domain as main-domain.


PHP interpreter versions (5 of 7 selected)
PHP 7.0
PHP 5.6
PHP 5.5
PHP 5.4
PHP 5 from OS vendor

Nginx web server and reverse proxy server (2 of 2 selected)
Nginx web server
PHP-FPM support from OS vendor

And the modules as you can see in the pic i ploaded.

Can you try to login on ?
It’s not really clear here, if you use nginx only as a reverse proxy. Also note that on apache it is recommended to use mod_php, with other solutions (apache+fcgi) there were a number of reports especially on systems managed with admin-panels. I had the impression that it is hard to figure out without deeper insights in Plesk (or any of the other systems).

Hi @tflidd,
Thank you for you quick reply. Yes, visiting works fine in all the ways without any problem. So what do you recommend for my server configs, and if you may be more specific how can i change or make those changes i would appreciate it.

If you use nginx as reverse proxy, you should make sure that all headers are passed. For the use of php with apache other than mod_php, I have never tried that and debugging probably need some knowledge of the whole webserver+php-setup of your server. I would check the plesk community and how others have implemented Nextcloud or owncloud.

All the guides from the documentation suppose that you have a single webserver with full control over the configuration.