'Nextcloud or one of the apps require upgrade' but there is no later version

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): 20.04.2
Apache or nginx version (eg, Apache 2.4.25): nginx/1.18.0
PHP version (eg, 7.4): 7.4

The issue you are facing:

After trying to set up and activate the Client Push App in nextcloud (not successful) I rolled back all changes and came into trouble with my nextcloud. I can reach the server via internet but nextcloud asks for an update to 21.0.2, also it’s already installed in this version.

Starting the upgrade via web updater ends in an error message with following information. Because it’s in German I will provide a short translation in brackets.

Update vorbereiten (preparing update)

Log-Level auf “debug” gesetzt (set log level to debug)

Wartungsmodus eingeschaltet (turn on maintenance mode)

Exception: Updates between multiple major versions and downgrades are unsupported.

Same error comes for starting the updater via occ. When working with occ commands, there always is the message “Nextcloud or one of the apps require upgrade - only a limited number of commands are available. You may use your browser or the occ upgrade command to do the upgrade”.

Turning off the maintenance mode always leads to the web updater, when opening the nextcloud.

What I completely do not understand is the message in the log of nexcloud, saying: “starting upgrade from 0.0.0 to”.

So I am not sure, if the updater stops because he wants to update from version 0 to 21 (skipping major versions) or because he tries to make an update from one version to the same version.

Is there any possibility to dismiss the update notification or disable the current update process?

I already tried to run occ maintenance:repair, checked the config file, where the correct version (21.0.2) is written and tried to do a manual update. But unfortunately nothing helped.

Does anyone has an idea why my nextcloud stucks here?

Thanks a lot and regards.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

Honestly, no idea how to reproduce it.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'XXXXX',
  'passwordsalt' => 'XXXXX',
  'secret' => 'XXXXX',
  'trusted_domains' =>
  array (
    0 => 'XXXXX',
    1 => 'XXXXX',
  'datadirectory' => '/var/nextcloud_data',
  'default_phone_region' => 'DE',
  'dbtype' => 'mysql',
  'version.' => '',
  'overwrite.cli.url' => 'http://XXXXX/nextcloud',
  'dbname' => 'nextcloud_db',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud_db_user',
  'dbpassword' => 'XXXXX',
  'installed' => true,
  'overwriteprotocol' => 'https',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'logtimezone' => 'Europe/Berlin',
  'maintenance' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'nextcloud',
  'mail_domain' => 'XXXXX',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => 'XXXXX',
  'mail_smtpport' => '587',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'XXXXX',
  'mail_smtppassword' => 'XXXXX',
  'theme' => '',
  'loglevel' => 0,
  'updater.release.channel' => 'production',
  'data-fingerprint' => 'XXXXX',


after some trying around, I figured out, that there was a minor mistake in the config file. :face_with_monocle:
In config-file, there is ‘version.’ and not ‘version’ written. Yes, just a fu**ing dot to much was the problem. :grimacing:
I guess, that nextcloud is not able to get the installed version, taking the standard value “0.0.0” and gets in trouble with the update.

So, using the occ command:

sudo -u www-data php occ config:system:get version

gave no output and I doubblechecked the config file again.

So, problem solved, weekend saved and happy again. Maybe this will help some else.

Thanks and by.