Nextcloud on UCS - OCC not available/found/working

Have anyone running Nextcloud in UCS managed to manually scan the storage using occ? e.g. sudo -u www-data php /var/www/nextcloud/occ
OCC is not to be found under common path /var/www… as it appear to be running in a Docker on UCS.

When searching for OCC I found multiple files buried inside one of the many Docker instances i.e. ‘/var/lib/docker/overlay2/2716fe8f6516cf56a89c38dff2db700c1e9fe037b45acc49aaf027b3f1416a72/merged/var/www/html’ but have not managed to run it from there either.

I’m not even sure what user to run it against. I’ve tried www-data, apache, root and all the other known users created in UCS by myself but no luck.

So if anyone have any ideas would be most welcomed.

UCS on current version as of 12th Jan 2020
Ready made Nextcloud Enterprise KVM appliance updated to on a Proxmox server

Did a duckduckgo and found this post might answer your question.

To run occ inside a container something like this is needed:

docker exec --user www-data “nextcloud-container-name” php occ “your-command”

Thanks Oliver for the prompt reply!

I did run the command but without any luck:
root@cloud:~# docker exec --user www-data b4bb15f0defa php occ files:scan --all
Could not open input file: occ

So will continue along the suggested path. Many thanks for pointing me to the relevant github page!

two thoughts…

  • have you tried putting your question at ucs-forum as well?
  • maybe you wanna install occweb-app to your instance and try again?

good luck

1 Like

I thought about posting on the UCS forum as well, but started here first.

I actually spotted the OCC web app just before reading your post and yes, that seem to work. Although scanning all fails after a few minutes, but at least I can run OCC commands. So some progression…


I understand this error as a php way to say ‘occ: file not found’
Maybe you tried to use the full path to the occ file (/var/www/html/occ) in the docker command without success ?
Regards. Aal.

As mentioned, I installed the occ app from the Nextcloud app repository, which worked. So I stopped wasting more time trying it in other ways