Nextcloud on Ubuntu Server 20.04 (Focal Fossa)

Maybe it’s something with your local DNS?

It works here, tested all the scripts once again today on Digitalocean.

Funny, I restarted my router and reinstalled it completely and now it works :wink:

Is it normal that you have to wait 90 seconds for the start-up process?

And I didn’t get this message during the first installation, kurt before the OnlyOffice deployment.

I am now looking around a bit with the new version …

Yes and no. It’s a bug so it’s not nomal. But since it’s a known bug it’s normal in 20.04 until the fix is released.

Never seen that before, maybe better to report it to the repository in question. In general, you need a decent internet connection to be able to download OnlyOffice - and a bit of luck that the app store isn’t DDOsed or something that makes it slow.

Outch. Some DDOS protection would be advisabe then.

Happens all the time. AFAIK they have protection against it, but since Nextcloud is quite popular, it’s also a popular target for idiots (excuse my french) on the internet with the sole purpose of destroying for others… :confused:

1 Like

Hello,
And first of all, thank you Daniel for your work.
As I felt brave (maybe a little too much), I chose to install with the scripts on a physical server freshly installed in 20.04. The first script ran without a hitch. and after the reboot, the launch of the second went generally well.

At the first launch of Nextcloud web interface, he complained about the absence of the “imagick” library, and after an installation of it, everything was correct. But after reading this thread (https://github.com/nextcloud/server/issues/13099), I removed it and only used PNG for the theme.

However, everything is not operational as I would like; because I had prepared 3 subdomains (cloud.mydomain.tld, oo.mydomain.tld and lo.mydomain.tld) ​​pointing to my server; so I checked both OnlyOffice and Collabora.
The installation of OO started and ended without problem, then that of Collabora launches and tells me that if I confirm, it will remove OO …
Since I personally chose ODF, I therefore let OO uninstall itself (and in the end Collabora does not work, but I will open another thread for that).

As indicated in this post (https://blog.genma.fr/?Cohabitation-Nextcloud-Collabora-Onlyoffice in French) the two document servers can coexist and launch according to the type of open file, to avoid the horrible conversions that OO performs on ODF files.
I also saw that, in your script, Collabora is installed as a Docker container; however there is also a container for OO (https://hub.docker.com/r/onlyoffice/documentserver/).

  • Is it possible (and planned) to make the two cohabit by installing them in this way?
  • If not, where are the difficulties, and what would be “good practice”?

Thank you

That was my mistake :wink: Sorry

The NC website has been banned because the cellphones are churning all the time to reach my “old” Nexcloud.

After deploying OnlyOffice, the following query is run

What is your recommendation?

I chose “No”.

Following the provision of Preview Generator, the following message appears.

What is your recommendation?

Icc provided it.

Thank you so much!

Hey!

If you’re not a Linux Sysadmin I recommend to use the VM instead. At least then you know that everything is installed correctly, and the only thing you have to to is to run the first setup.

The scripts work as intended, that I know for a fact as I’m always testing them (every day actually) before release. I also recently (yesterday) did a full installation with all available apps, dockers etc on Digitalocean - everything checked out perfectly.

The scripts supports one Office server at the time, hence the other is removed if you choose to install another option if another already exists. That’s a feature.

Not installing Imagick is also a feature, which is documented in the prompt of the script, from which I’m sure you got the issue on Github, since it’s linked in the prompt.

So all and all:

  • Nextcloud requires one domain
  • Collabora another
  • OnlyOffice works without any need for an extra domain.
  • The scripts are smart enough to know which one is which, and automatically de-installs or re-installs based upon your choices.

Its not possible to run the VM on more than two domains, if you don’t make your own custom changes - which is possible as well, since the system isn’t locked down in any way.

Hope it helps!

If you’re not sure about what you should choose, just hit enter and choose the default value. :slight_smile:

Do your research and make your own decision, that’s my recommendation. :+1:

1 Like

I’m sorry to bother you again, unfortunately I have something new, sorry.

When I add external CIFS storage, exit the menu and go back to it later, the CIFS share is shown twice.

The cifs deployment doesn’t work either. When I click on it, the following error message appears.

Is there any connection with shared folder?
Because I activated that.

I do not give up :wink:

@szaimen Please have a look :point_up:

When I add external CIFS storage, exit the menu and go back to it later, the CIFS share is shown twice.

This is a known Nextcloud bug. You can safely delete one of them.

The cifs deployment doesn’t work either. When I click on it, the following error message appears.

This seems to be a Nextcloud bug as well. But I guess it is because you try to add a network share with a space in it?
I would suggest that you use the built-in apps-script to mount a cifs-share to your VM.

Is there any connection with shared folder?
Because I activated that.

No, that is not related.

I do not give up :wink:

Thats good :+1:

2 Likes

Blockquote This is a known Nextcloud bug. You can safely delete one of them.

Thank you for the information. Yes, that’s right, I can delete one. Still doesn’t work after deleting.

Blockquote I would suggest that you use the built-in apps script to deploy a CIFS share on your VM.

It works, perfect, wonderful -> Thank you very much!
Access is faster. I saw the setup menu a thousand times and didn’t dare :wink: I only knew the way via the web interface.

The result :wink:

Slowly I bring my NC back into operation … Good … now I still need the Midnight Commander without damaging the system :slight_smile: and a real VMWare backup (not at file level)

I only need contacts / calendars and pictures (cell phone) for the family. I don’t want to be addicted to Google.

Thanks to DH -> Ubuntu 20 works :wink:

1 Like

Thats good to hear, thanks for the feedback!

As a sidenote: you should change the name of the external storage folders (SMB1 and SMB2) to something else, as it was recommended during the setup.

Thanks for great support @szaimen!

1 Like

@enoch85

Hi Daniel,

I want to use the Midnight Commander.
I would do the following:

I make a copy of the source.list:
sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak

Then I add the source “Universe” to the repsitorium.
udo add-apt-repository universe

Reload package sources:
sudo apt-get update

Deploy MC:
sudo apt install mc

With the MC I restore the original “source.list”.

Can I do it like this?
Or is it dangerous for your VM?

The VM is basically Ubuntu OS with some tweaks (a lot of them) and an optimized Nextcloud installation. In other words, it’s nothing special about it in regards of being a server. You are free to do what you want with it.

If it’s safe? I have no opinion in that matter as I know to little about MC, but in general, changing sources.list just adds repos - question is, can you trust the supplier?

I don’t think anything but a single command
sudo apt-get install mc
was ever needed to install Midnight Commander on Ubuntu (including 20.04)…

3 Likes

Man soll angeblich teure € bezahlen zum runterladen?

No, the 40 GB version is free. :slight_smile: