Nextcloud on Ubuntu Server 20.04 (Focal Fossa)

Hi Daniel,

Thank you for asking :wink: My VM is running very well, I am very satisfied. Everything works. I have now installed MC without problems and did not have to change the sources.list.

I have deactivated the automatic Saturday update, I have too much respect for it. I do it manually once a month now that you have published it on your homepage.

For your information. I have also activated NFS and it works. I know it’s a security risk, but I’m not a bank and I need my videos. I added the following to the fstab and it works: XXX.XXX.XXX.XXX:/nfsshare /mnt/nfs/video nfs defaults 0 0

I wanted the MC menu in German. I have adapted the language for this:
sudo dpkg-reconfigure locales

After that, the web interface no longer works. I have restored the VM snapshot.

I will test this again in peace.

Now I hope that the NC stays alive for a long time :wink: Before I make any changes, I switch off the server and take a snapshot beforehand.


I was finally able to put my bare-metal server online for our association.
I analyze the way it is built and I try to understand how to administer it well (update of the Ubuntu base, Nextcloud and its applications, and docker images which are part of it).

I twice lost the link between Nextcloud and Collabora (.odt files would no longer open, with a connection error message, but why ?), but reinstalling Collabora fixed the problem.

Until this morning, when the “richdocuments” application went to 3.6.0, and the reinstallation of Collabora could not do anything.

After searching on this forum, I found the solution here
Adding the two lines indicated by ‘helge’ and relaunching Apache fixes the problem.

But I realized that, despite the fact that I did an Nextcloud update (at least I thought so) with the script:
sudo bash /var/scripts/,
I didn’t see any changes in this scripts directory, in particular, the script is not present, although it seems to be part of the scripts copied during the global installation.
Also, the versions of the scripts on my machine and on the master branch of git are not the same.

Is it possible to update the script directory to stay at the git level, and is there a script to do it?
Would relaunching a full installation do this job without breaking existing configuration items?

PS: I am an old retired IBM AIX sysadmin :wink: and I’m not very comfortable with docker :thinking:

Hi, gets the latest and runs that, but it doesn’t download all the latest scripts from Github, New functions and scripts are only released in new versions of Nextcloud, and regarding that’s not released until Nextcloud 19 or 18.0.5. You could download it manually though - it will run, and it will work with the current file.

Hope it helps!

1 Like

Just an little FYI. Nextcloud 19 is now released and it’s even faster than before. :rocket:

Hi Daniel,
I updated your NC version to NC19.

The first attempt failed. I think the SSH Putty console was to blame.

The second attempt was positive. I deployed it from the VSphere console.

I had two messages after installing it. I can edit the first message alone.

cd /var/www/html/nextcloud
sudo -u www-data php occ db:add-missing-columns

The second message says that I should provide / update the PHP module “bcmath”. I chose a command from the Internet:
apt install php-bcmath

Should I do it or not? I don’t know if your update script will have a problem with it later.

Thanks a lot


This was added in NC 19 before it was released:

I don’t know why the check didn’t kick in and added the config. I would have to take a look at it, when I have time.

Anyway, it should be sorted in 19.0.1, but if you want to can just run it ḿanually. In the VM you can use nextcloud_occ as an alias for running the occcommand.

Just tested here, and it worked for me, so it must have been something temporary.

Remember, you must run sudo bash /var/scripts/ to get the latest changes in the update script.

Cool it worked, I’m proud of myself :wink:

First I started the update process with ssh and putty and it showed the same error as before and I had to cancel the update to NC19, restore the snapshot and start again.

Then I updated Ubuntu with sudo apt-get update and sudo apt-get upgrade and started again.

Then I repeated the update script: sudo bash /var/scripts/

In the meantime I was asked to run sudo dpkg --configure -a. After that everything went smoothly.

Now I’m going to look at the nice new NC19 version.

I’ll wait two days and then delete the snapshot.

Thanks a lot

1 Like
Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

How do you expect to help you such less information?

Please add all necessary information like log entries, environment information …

1 Like

This doesn’t seem to be the VM either as it doesn’t follow the VM standards.

The other post is better suited for the issue. :point_up:

Please open an own thread with all needed information. Thanks.

Seems like he did:

Which information do you need besides the one that already exists?

Please, note exactly which logs and environment info do you need more to be able to help in my case?

Hi enoch85

When updating to 19.0.2 I get the following message:

When I issue the command, the file or directory cannot be found:

sudo bash /var/scripts/

What am I doing wrong?

thank you


You shouldn’t run the startup script for update. The fact that it’s still there tells me that something went wrong during the initial run, or you didn’t reboot the server properly. The last thing that happens is that the startup script is removed. but it only happens if you reboot.

The correct way of updating is using the update script:

sudo bash /var/scripts/

Hope it helps! :slight_smile:

It helped :wink:

The start script was suppressed :wink: I ran it a second time and then everything worked. I took the message as an instruction. I thought it was the normal process. Thank you and have a nice weekend.

1 Like

I have installed it a few days ago and it runs perfectly.


Great, thanks! :smiley: