Nextcloud Office - Scrolling issue in Spreadsheets on mobile

Nextcloud version : 28.0.4
Operating system and version (eg, Ubuntu 20.04): Synology/Linux
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4
PHP version (eg, 7.4): PHP 8.2
Collabora Docker 29.0.5

The issue you are facing:

When scrolling in spreadsheets on mobile devices (no matter if via browser or directly in the NC client) the view jumps back to the first rows and collumns. It semms to happen only, if there is content in the spread sheet. In an empty spreadsheet, scrolling worked laggy but didn’t jump back. it is impossible to move to lines or coloumns outside the start view.

Is this the first time you’ve seen this error? (Y/N): no, happend with other versions of NC and Collabora too

Steps to replicate it:

  1. Open a spreadsheet
  2. Scroll

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:


Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.


which mobile? which OS-version? Which client version?
What connection?
Where/how hosted - in your case: how installed?

Mobile: Android 14 (Update 5.April 24) on a Google Pixel 8
NC Client: 3.28.2
Connection: Wifi and LTE
NC installed via web installer
Collabora installed via official Docker Image

DSM comes with a version number itself… which one?

Why do I ask this? Because I have it installed on DSM as well, using a VM-docker and it runs flawlessly (using the same Android and NC-client)

So directly installed… but where? Into a VM? Or Docker? Or What?

DSM is on 7.1 latest Update, running on a DS 1522
NC is installed directly on the Webserver/Web Station
The collabora container does not have any resource limitations and there is plenty of RAM left and CPU is ok, jumps between 20 and 30%, when opening on mobile or on desktop, but on desktop it is fluent and doesn’t jump.

DSM is known for being a bit special.
Maybe it’s because of that.

If you want you could get a share to a test-spreadsheet out and I would test it with my mobile on your server (you can email the share to me if you’re afraid to post it here on the forum)… and so we maybe would be able to find out if it’s a general problem or something more special.

1 Like

well well well… it means carrying owls to Athens :wink: You seem to know that yourself :wink:

Ok, they sent me a test-sheet and I opened it with my pixel (6a) running android 14 and scrolled left and right, up and down like crazy. it didn’t jump anyhwere but acted as it should have been acting.

So this would mean: setup on your Synology seems to be correct… it looks like a problem from the side of your mobile…

As you said that you’re running the newest Android as well as the newest NC-app I’m lost here.

Have you tried other mobiles?

Yes, I tried my Pixel 8, my old OnePlus 8T and a Samsung. All the same, or at least almost.

I tried a different browser. I use mainly Brave, tried it on Chrome and vertical scrolling worked a bit laggy, but it worked. As soon as I came to horizontal scrolling, it jumped again. The Samsung is using some other Browser, where I had the same behaviour as on Chrome.

OnlyOffice works without any issues, btw.
I will try around for some time but it seems I have to go back to OO again. Viewing files on mobile is something that I use more often than editing.

Thank you for your help anyway.

1 Like

last question: have you tried it from outside of your own Wifi?

Outside mainly, I’m rarely on Wifi with my phone. But tested on Wifi aswell, both the same.