Nextcloud Office » Copy-pasting disabled

I am using Nextcloud in version 24.04 and a separate installation of Collabora Online (CODE) 22.05.6.1.

Since today’s update of the Nextcloud Office app, one user gets the error message “Copying from the document disabled” when trying to copy-paste values from a spreadsheet in Nextcloud into an offline spreadsheet (Excel). The message appears in the target spreadsheet instead of the chosen values.
The user has full document access, no external sharing link.

I cannot reproduce the issue on my computer.

Does anyone know what I can do to fully allow copy-pasting?

1 Like

I know now that it affects all user accounts except of mine, but sharing the file as an external link works.

At the moment I can’t reproduce the problem. I used NC 24.0.5 with richdocuments 6.2.0 and separate Collabora 22.05… (all Docker but this should not matter)

  • created new file, which I shared for anonymous write access
  • Tested Copy&paste using shared URL - copy&paste works
  • upgraded richdocuments to 6.2.1
  • tested again using the old share URL - copy&paste works
  • created new share with write access, tested again using the new share URL - copy&paste works

In the past I have seen this issue but I don’ t remember the cause I think it was some protection feature

Yes, and I can’t see any suitable protection feature. I can’t reproduce it either, but I have seen the screencast, so this is really an issue.

from your original post I missed the important point “one user” is affected… Please double check this user still has an issue using “private” or “incognito” mode… most likely this is something related to local browser cache and can be resolved by removing local data…

Actually, I just tried to impersonate the user using the respective app and when I try to copy-paste from her account, it doesn’t work for me either. So, this must be account-related and probably affects multiple users, but perhaps not everyone has tried it yet.

I could narrow the issue down to Nextcloud 24.04, everything worked in Nextcloud 24.06.

It was a wrong direction, the issue remains after upgrading the installation I have used to 24.06.

sounds like this:

but the problem described was for shares and not internal users with full access…

but the referenced issue might be interesting:

this is how I can reproduce the problem. If you copy from Collabora document and past “unformatted text” the string “Stub HTML Message Copying from this document disabled” is pasted in local LibreOffice Calc

1 Like

Thank you for pointing this out!

Where should I post this mentioned code fix, though?

The latest app update has resolved the issue.