NextCloud Office cannot display Chinese and Japanese correctly

Hi all,

NextCloud Office cannot display Chinese and Japanese correctly. How to troubleshoot? Please help! Many thanks!

Best Regards,

OS: Rocky Linux 9.4
Apache 2.4.57
PHP 8.3.6 (remi-modular)
MairaDB: 10.5.22-MariaDB

Nextcloud: 28.0.6

COOLWSD version: hash: [80a6f97](javascript:void(‘Commits · CollaboraOnline/online · GitHub’));)(E)

LOKit version:

built on [a great technology base](javascript:void(‘’)):wink:

Collabora Office hash: [4fe480d](javascript:void(‘Log - 4fe480d - core - Gitiles’)):wink:

Served by: Rocky Linux 9.4 (Blue Onyx) 52ea1ddd

“Slow Proxy”

Try to use different fonts

Many thanks for your help! Is it possible to set the default font for Chinese/Japanese? (for example, if the font is not exist on NC office, use the default Chinese/Japanese to display it.)

Frankly speaking I have never tried. But I think it is possible to install additional fonts, say, from Microsoft, which are more universal or find existing universal font and enable it as default.
I think you should check this thread: Installing new fonts in Collabora - #13 by chiuyau

I am sorry, I have no time at the moment to try this proposal by myself now but maybe will do it later.