Nextcloud Office and ONLYOFFICE


I am a Trainee who is currently testing Nextcloud Office and ONLYOFFICE.

Since I never used one of them before nor have any knowledge about format-types like .docx, .odt or .doc. It is hard to tell which of them is better. Cause so far both are not working as they should. Everything is running on a cloudron-instance. The Nextcloud and the both server we need to connect the tools with the Nextcloud. For that I use the ONLYOFFICE Docs App and the Collabora Online App. In both I just have to set the link to the Nextcloud-Instance where I want to use the tools.

Side Fact: When you have both of the tools activated (and setup with the link to the two cloudron-apps), you have two options to create a “Document”, “Presentation” and “Spreadsheet”. It doesn’t matter which of the options you choose, Nextcloud Office will always be the tool that tries to open the document. When you rightclick a created document, you have the possibility to open it via ONLYOFFICE.

Now let’s take a look to the problems I faced during my time with ONLYOFFICE and Nextcloud Office:

1. Problem I faced was the error “Failed to load Nextcloud Office - Please try again later”


  1. Click on 
  2. Select a "New Document"
  3. Loading
  4. Fail "Failed to load Nextcloud Office - Please try again later" (Same with existing Documents)
  • it was hard to find the solution cause I am just at the beginning of my education and I didn’t set up the Nextcloud
  • most of the fixes didn’t seem like they could fit to my problem
  • to try diff settings I created a whole new Nextcloud Instance and tried some settings → it didn’t work either (even tho it was a fully fresh system)
  • after some time I found out that the WOPI IP-Adress wasn’t correct (on the old Nextcloud-Instance)
  • I removed it, and apparently it worked (on the old Nextcloud-Instance)

2. The problem with .odt documents


  1. Tried to open an .odt Document
  2. Connected to the Nextcloud Office UI
  3. Nothing loaded in the Document
  4. Notification in the top left corner > "admin disconnected" (I was the admin)
  5. It connects and disconnects till I close the document
  • the basic format you get with Nextcloud Office (unless you changed the settings) is .odt
  • now I tried to open a document.odt, the file opens but then I always get the notification “admin
    disconnected”, then it connects again and disconnects again

=> this means I can’t do anything with the file


3. When I have a .odt-File in ONLYOFFICE and I want to print it, the print preview is empty. When I convert the .odt to .docx with ONLYOFFICE the print preview is broke any fix?


  1. Opened any .odt File
  2. cmd + p to print
  3. print preview is empty
  4. convert the .odt to .docx via ONLYOFFICE
  5. cmd + p to print
  6. print preview looked diff then the original document

4. I again created a new instance to make some more tests to find out if we should use ONLYOFFICE or Nextcloud Office.

  • I installed a completely fresh Nextcloud as a Cloudron App and also 2 new Apps for the tools. ONLYOFFICE Docs and Collabora Online
  • Even with the same settings from the old instance for Nextcloud Office I get the error “Failed to load Nextcloud Office - please try again later”
  • When I check the console while opening/ creating a file with Nextcloud Office I see this error: “FAILED
    → loadingTimeout Office.vue:202”
  • ONLYOFFICE works just fine


  1. Click on the "+"
  2. Select a "New Document"
  3. Loading
  4. Fail "Failed to load Nextcloud Office - Please try again later"
  5. (Same with existing Documents)

It is kinda frustrating when you just want to test the usability and nothing works as expected. Maybe it would be easier if I had the necessary knowledge.
Do you guys also had so much trouble with setting it up?

Cause I don’t get how something that simple is so confusing to set up and use.

It might be easier to get a really good setup with the docker all in one container.

1 Like

First, thank you Daphne for the reply. I prefer to fix it.

I now tried to open the older document (.odt) with the Built In Collabora Online (CODE) App. And it worked. It is weird, second try it didn’t work. Third try it worked, now it works.

So I guess the cloudron app for Collabora Online isn’t compatible with something from the document.

We tested how LibreOffice would behave with this kind of document. And when I opened the document in LibreOffice. It said “Missing hyphenation […]”.

It all feels so weird to use, did anyone ever had problems like this before?