Nextcloud not accepting correct passwords


#1

I recently installed nextcloud with nextcloudpi. It was a bit of a bumpy ride, but after installing all of the missing php modules, the web interface seems all well and good.
However, when I try to log in to the default ncp account, it tells me I have the wrong password. Before trying, I had changed the password in the NCP interface, and discarded the original random one NCP generated for me. I’ve tried resetting the password through the NCP web interface, ncp-config and sudo -u www-data php occ user:resetpassword ncp, and still none of these worked. I then updates to nextcloud 15 and ran nc-init, with still no avail.
I have also checked that the system time on my Pi is correct through date, as I saw this mentioned online.
Any ideas? Thanks

edit:
I forgot to mention that I also created a new user with the occ command, and couldn’t log in as this user either.
I have attempted to log in through a browser and client application on my computer and phone.


#2

Which image did you use? You should not have to install php modules. Or need to use occ.
Please use the latest image
Sorry but we just don’t have enough manpower to support older images.


#3

I didn’t use an image as I was already using the Pi for other things, instead I ran curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | sudo bash


#4

That might explain the issues you are having.
There have been changes upstream affecting the curl installer.
Again lack of manpower, no one with time to look into and fix it at the moment.
So unless someone turns up to fix it or help you…
best make a fresh start with latest image, no issues reported there :wink:


#5

ok thank you for letting me know.

I will open a github issue so it is known, incase anyone can find a solution.


#6

Issue already there, dont create a new one please.


#7

that looks like a different issue? or does the sql error cause this one?